summaryrefslogtreecommitdiffstats
path: root/recipes/grep/grep-native_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/grep/grep-native_2.5.1.bb')
-rw-r--r--recipes/grep/grep-native_2.5.1.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/grep/grep-native_2.5.1.bb b/recipes/grep/grep-native_2.5.1.bb
new file mode 100644
index 0000000000..abc2ea46cb
--- /dev/null
+++ b/recipes/grep/grep-native_2.5.1.bb
@@ -0,0 +1,13 @@
+require grep_${PV}.bb
+inherit native
+
+S = "${WORKDIR}/grep-${PV}"
+
+do_stage () {
+ install -d ${STAGING_BINDIR}
+ install -m 755 src/grep ${STAGING_BINDIR}
+ install -m 755 src/egrep ${STAGING_BINDIR}
+ install -m 755 src/fgrep ${STAGING_BINDIR}
+}
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/grep-${PV}"