summaryrefslogtreecommitdiffstats
path: root/recipes/grep
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/grep')
-rw-r--r--recipes/grep/grep-2.5.1/uclibc-fix.patch52
-rw-r--r--recipes/grep/grep-2.5/install.patch15
-rw-r--r--recipes/grep/grep-native_2.5.1.bb13
-rw-r--r--recipes/grep/grep_2.5.1.bb37
-rw-r--r--recipes/grep/grep_2.5.bb15
5 files changed, 132 insertions, 0 deletions
diff --git a/recipes/grep/grep-2.5.1/uclibc-fix.patch b/recipes/grep/grep-2.5.1/uclibc-fix.patch
new file mode 100644
index 0000000000..f67177f6ab
--- /dev/null
+++ b/recipes/grep/grep-2.5.1/uclibc-fix.patch
@@ -0,0 +1,52 @@
+Fix to use mempcpy instead of __mempcpy. This is needed for uclibc which
+doesn't define __mempcpy only mempcpy. Since both uclibc and glibc have
+mempcpy we'll just use that instead.
+
+Index: grep-2.5.1/intl/localealias.c
+===================================================================
+--- grep-2.5.1.orig/intl/localealias.c 2002-03-14 00:39:06.000000000 +1100
++++ grep-2.5.1/intl/localealias.c 2007-05-17 13:53:58.000000000 +1000
+@@ -65,7 +65,7 @@
+ # define strcasecmp __strcasecmp
+
+ # ifndef mempcpy
+-# define mempcpy __mempcpy
++# error "mempcpy not detected"
+ # endif
+ # define HAVE_MEMPCPY 1
+ # define HAVE___FSETLOCKING 1
+Index: grep-2.5.1/lib/getopt.c
+===================================================================
+--- grep-2.5.1.orig/lib/getopt.c 2001-03-04 16:33:12.000000000 +1100
++++ grep-2.5.1/lib/getopt.c 2007-05-17 13:51:44.000000000 +1000
+@@ -326,7 +326,7 @@
+ nonoption_flags_len = nonoption_flags_max_len = 0;
+ else
+ {
+- memset (__mempcpy (new_str, __getopt_nonoption_flags,
++ memset (mempcpy (new_str, __getopt_nonoption_flags,
+ nonoption_flags_max_len),
+ '\0', top + 1 - nonoption_flags_max_len);
+ nonoption_flags_max_len = top + 1;
+@@ -437,7 +437,7 @@
+ if (__getopt_nonoption_flags == NULL)
+ nonoption_flags_max_len = -1;
+ else
+- memset (__mempcpy (__getopt_nonoption_flags, orig_str, len),
++ memset (mempcpy (__getopt_nonoption_flags, orig_str, len),
+ '\0', nonoption_flags_max_len - len);
+ }
+ }
+Index: grep-2.5.1/lib/regex.c
+===================================================================
+--- grep-2.5.1.orig/lib/regex.c 2001-04-03 04:04:45.000000000 +1000
++++ grep-2.5.1/lib/regex.c 2007-05-17 13:51:48.000000000 +1000
+@@ -7842,7 +7842,7 @@
+ if (msg_size > errbuf_size)
+ {
+ #if defined HAVE_MEMPCPY || defined _LIBC
+- *((char *) __mempcpy (errbuf, msg, errbuf_size - 1)) = '\0';
++ *((char *) mempcpy (errbuf, msg, errbuf_size - 1)) = '\0';
+ #else
+ memcpy (errbuf, msg, errbuf_size - 1);
+ errbuf[errbuf_size - 1] = 0;
diff --git a/recipes/grep/grep-2.5/install.patch b/recipes/grep/grep-2.5/install.patch
new file mode 100644
index 0000000000..cbb9229a8e
--- /dev/null
+++ b/recipes/grep/grep-2.5/install.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- grep-2.5/src/Makefile.am~install
++++ grep-2.5/src/Makefile.am
+@@ -18,5 +18,5 @@
+ vms_fab.c vms_fab.h
+
+ install-exec-local:
+- @SYMLINK@ @SYMLINKFROM@ $(bindir)/egrep
+- @SYMLINK@ @SYMLINKFROM@ $(bindir)/fgrep
++ @SYMLINK@ @SYMLINKFROM@ $(DESTDIR)$(bindir)/egrep
++ @SYMLINK@ @SYMLINKFROM@ $(DESTDIR)$(bindir)/fgrep
diff --git a/recipes/grep/grep-native_2.5.1.bb b/recipes/grep/grep-native_2.5.1.bb
new file mode 100644
index 0000000000..abc2ea46cb
--- /dev/null
+++ b/recipes/grep/grep-native_2.5.1.bb
@@ -0,0 +1,13 @@
+require grep_${PV}.bb
+inherit native
+
+S = "${WORKDIR}/grep-${PV}"
+
+do_stage () {
+ install -d ${STAGING_BINDIR}
+ install -m 755 src/grep ${STAGING_BINDIR}
+ install -m 755 src/egrep ${STAGING_BINDIR}
+ install -m 755 src/fgrep ${STAGING_BINDIR}
+}
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/grep-${PV}"
diff --git a/recipes/grep/grep_2.5.1.bb b/recipes/grep/grep_2.5.1.bb
new file mode 100644
index 0000000000..6d184b8c4c
--- /dev/null
+++ b/recipes/grep/grep_2.5.1.bb
@@ -0,0 +1,37 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "grep GNU utility"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
+ file://uclibc-fix.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
+
+do_configure () {
+ rm -f ${S}/m4/init.m4
+ autotools_do_configure
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+}
+
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
+ update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
+ update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove grep grep.${PN}
+ update-alternatives --remove egrep egrep.${PN}
+ update-alternatives --remove fgrep fgrep.${PN}
+}
diff --git a/recipes/grep/grep_2.5.bb b/recipes/grep/grep_2.5.bb
new file mode 100644
index 0000000000..6685cf70ac
--- /dev/null
+++ b/recipes/grep/grep_2.5.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "grep GNU utility"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
+ file://install.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
+
+do_configure () {
+ rm -f ${S}/m4/init.m4
+ autotools_do_configure
+}