aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gs/gs_8.64.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gs/gs_8.64.bb')
-rw-r--r--recipes/gs/gs_8.64.bb41
1 files changed, 38 insertions, 3 deletions
diff --git a/recipes/gs/gs_8.64.bb b/recipes/gs/gs_8.64.bb
index 9aac182a98..74cdcbf167 100644
--- a/recipes/gs/gs_8.64.bb
+++ b/recipes/gs/gs_8.64.bb
@@ -3,7 +3,7 @@ LICENSE = "GPL"
SECTION = "console/utils"
HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
DEPENDS = "jpeg zlib fontconfig cups"
-PR = "r2"
+PR = "r3"
SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.gz;name=tarball \
file://0001_svn_snapshot.patch \
@@ -16,6 +16,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.g
file://1007_fix_pphs_script_not_lib.patch \
file://2001_docdir_fix_for_debian.patch \
file://2002_gs_man_fix_debian.patch \
+ file://unix-aux.mak \
"
SRC_URI[tarball.md5sum] = "e42706c2409815df5c959484080fd4a3"
@@ -26,12 +27,22 @@ S = "${WORKDIR}/ghostscript-${PV}~dfsg"
inherit autotools
-EXTRA_OECONF = "--without-x --with-jasper --with-zlib=${STAGING_DIR_HOST}${layout_prefix}"
+EXTRA_OECONF = "--without-x --with-jasper --with-zlib=${STAGING_DIR_HOST}${layout_prefix} --with-fontpath=${datadir}/fonts"
TARGET_CC_ARCH += "${LDFLAGS}"
PACKAGES += "cups-gs"
+do_configure_prepend() {
+ CC="${BUILD_CC}" LD="${BUILD_LD}" ./configure
+ mkdir obj
+ for i in genarch genconf mkromfs echogs gendev genht; do
+ make obj/$i
+ done
+ mv obj obj_host
+ make clean
+}
+
do_configure() {
# hack script to allow for cross compiling
sed 's,&& ./configure$,& --host=\$host --build=\$build --target=\$target,g' -i configure
@@ -40,6 +51,21 @@ do_configure() {
oe_runconf
}
+do_configure_append() {
+ if [ ! -d obj ]; then
+ mkdir obj
+ fi
+ if [ ! -d soobj ]; then
+ mkdir soobj
+ fi
+ for i in genarch genconf mkromfs echogs gendev genht; do
+ cp obj_host/$i obj/$i
+ cp obj_host/$i soobj/$i
+ done
+ # Prevent mkromfs from being recompiled for the target
+ cp ${WORKDIR}/unix-aux.mak base/
+}
+
do_stage () {
install -d ${STAGING_INCDIR}/ghostscript
install -m 755 ${S}/psi/*.h ${STAGING_INCDIR}/ghostscript/
@@ -50,11 +76,20 @@ do_compile_append () {
oe_runmake so
}
+do_install_prepend () {
+ sed -e 's#CUPSSERVERBIN=${STAGING_LIBDIR}/cups#CUPSSERVERBIN=${libdir}/cups#g' -i ${S}/Makefile
+ sed -e 's#CUPSDATA=${STAGING_DATADIR}/cups#CUPSDATA=${datadir}/cups#g' -i ${S}/Makefile
+}
+
do_install_append () {
oe_runmake 'DESTDIR=${D}' soinstall
+ # recent cups expects this file in /usr/share/cups/mime
+ # so duplicate it for compatibility
+ mkdir -p ${D}/${datadir}/cups/mime/
+ cp ${D}/etc/cups/pstoraster.convs ${D}/${datadir}/cups/mime/
}
FILES_${PN} += "${datadir}/ghostscript"
-FILES_cups-gs = "${libdir}/cups/filter/* ${datadir}/cups ${sysconfdir}/cups"
+FILES_cups-gs = "${libdir}/cups/filter/ ${datadir}/cups ${sysconfdir}/cups"
RDEPENDS_cups-gs += "gs"