aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsm/pty_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gsm/pty_0.0.bb')
-rw-r--r--recipes/gsm/pty_0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/gsm/pty_0.0.bb b/recipes/gsm/pty_0.0.bb
new file mode 100644
index 0000000000..ab767f7979
--- /dev/null
+++ b/recipes/gsm/pty_0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Forwards a socket to a tty"
+LICENSE = "GPLv2"
+PR = "r1"
+
+SRC_URI = "file://pty.c"
+
+do_compile() {
+ cp ${WORKDIR}/*.c ${S}/
+ ${CC} pty.c -o pty -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 pty ${D}${bindir}/
+}