aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoap/gsoap_2.7.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gsoap/gsoap_2.7.13.bb')
-rw-r--r--recipes/gsoap/gsoap_2.7.13.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/gsoap/gsoap_2.7.13.bb b/recipes/gsoap/gsoap_2.7.13.bb
new file mode 100644
index 0000000000..54f89c68fc
--- /dev/null
+++ b/recipes/gsoap/gsoap_2.7.13.bb
@@ -0,0 +1,15 @@
+require gsoap_${PV}.inc
+
+DEPENDS = "gsoap-native"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
+ do
+ oe_libinstall -C gsoap $lib ${D}${libdir}
+ done
+}
+
+
+FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
+FILES_${PN} += "${datadir}"