aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gspcav1/gspcav1_20071224.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gspcav1/gspcav1_20071224.bb')
-rw-r--r--recipes/gspcav1/gspcav1_20071224.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gspcav1/gspcav1_20071224.bb b/recipes/gspcav1/gspcav1_20071224.bb
new file mode 100644
index 0000000000..c6ab5f689e
--- /dev/null
+++ b/recipes/gspcav1/gspcav1_20071224.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/gspcav1-${PV}.tar.gz \
+ file://Makefile-fix-cc-quoting.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/gspcav1-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}