aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gstreamer/gst-plugin-pulse_0.9.7.bb')
-rw-r--r--recipes/gstreamer/gst-plugin-pulse_0.9.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb b/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
new file mode 100644
index 0000000000..cfa200ef3d
--- /dev/null
+++ b/recipes/gstreamer/gst-plugin-pulse_0.9.7.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
+HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
+LICENSE = "GPL"
+DEPENDS = "gstreamer pulseaudio gst-plugins-base"
+PR = "r1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz \
+ file://dont-overload-pulseaudio.patch;patch=1"
+S = "${WORKDIR}/gst-pulse-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-lynx"
+GST_LIBV = 0.10
+
+do_install() {
+ install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
+ install -m 0755 src/.libs/libgstpulse.so ${D}${libdir}/gstreamer-${GST_LIBV}
+}
+
+export GST_MODDIR=${libdir}/gstreamer-0.10
+
+FILES_${PN} = "${libdir}/gstreamer-0.10/libgstpulse.so"
+FILES_${PN}-dev = "\
+ ${libdir}/gstreamer-0.10/libgstpulse.a \
+ ${libdir}/gstreamer-0.10/libgstpulse.la \
+ ${libdir}/gstreamer-0.10/libgstpulse.so*"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+