aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gstreamer/gst-plugins-ugly_0.10.11.bb')
-rw-r--r--recipes/gstreamer/gst-plugins-ugly_0.10.11.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb b/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb
new file mode 100644
index 0000000000..062404179e
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-ugly_0.10.11.bb
@@ -0,0 +1,16 @@
+require gst-plugins.inc
+
+DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
+
+SRC_URI += "\
+ file://gstmad_16bit.patch;patch=1 \
+ file://gstsid_autofoo_HACK.patch;patch=1 \
+"
+
+python() {
+ # Don't build, if we are building an ENTERPRISE distro
+ enterprise = bb.data.getVar("ENTERPRISE_DISTRO", d, 1)
+ if enterprise == "1":
+ raise bb.parse.SkipPackage("gst-plugins-ugly will only build if ENTERPRISE_DISTRO != 1")
+}
+