summaryrefslogtreecommitdiffstats
path: root/recipes/gtk-doc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtk-doc')
-rw-r--r--recipes/gtk-doc/gtk-doc-native.bb3
-rw-r--r--recipes/gtk-doc/gtk-doc.bb16
-rw-r--r--recipes/gtk-doc/gtk-doc.m453
3 files changed, 72 insertions, 0 deletions
diff --git a/recipes/gtk-doc/gtk-doc-native.bb b/recipes/gtk-doc/gtk-doc-native.bb
new file mode 100644
index 0000000000..60a8907baf
--- /dev/null
+++ b/recipes/gtk-doc/gtk-doc-native.bb
@@ -0,0 +1,3 @@
+SECTION = "x11/base"
+inherit native
+require gtk-doc.bb
diff --git a/recipes/gtk-doc/gtk-doc.bb b/recipes/gtk-doc/gtk-doc.bb
new file mode 100644
index 0000000000..f0dbdd0bae
--- /dev/null
+++ b/recipes/gtk-doc/gtk-doc.bb
@@ -0,0 +1,16 @@
+SECTION = "x11/base"
+SRC_URI = "file://gtk-doc.m4"
+LICENSE = "LGPL"
+PR = "r2"
+
+ALLOW_EMPTY_${PN} = "1"
+
+do_install() {
+ install -d ${D}/${datadir}/aclocal
+ install -m 0644 ${WORKDIR}/gtk-doc.m4 ${D}/${datadir}/aclocal
+}
+
+do_stage() {
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${WORKDIR}/gtk-doc.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/gtk-doc/gtk-doc.m4 b/recipes/gtk-doc/gtk-doc.m4
new file mode 100644
index 0000000000..af73800bf2
--- /dev/null
+++ b/recipes/gtk-doc/gtk-doc.m4
@@ -0,0 +1,53 @@
+dnl -*- mode: autoconf -*-
+
+# serial 1
+
+dnl Usage:
+dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
+AC_DEFUN([GTK_DOC_CHECK],
+[
+ AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
+ AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
+ dnl for overriding the documentation installation directory
+ AC_ARG_WITH(html-dir,
+ AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
+ [with_html_dir='${datadir}/gtk-doc/html'])
+ HTML_DIR="$with_html_dir"
+ AC_SUBST(HTML_DIR)
+
+ dnl enable/disable documentation building
+ AC_ARG_ENABLE(gtk-doc,
+ AC_HELP_STRING([--enable-gtk-doc],
+ [use gtk-doc to build documentation [default=no]]),,
+ enable_gtk_doc=no)
+
+ have_gtk_doc=no
+ if test x$enable_gtk_doc = xyes; then
+ if test -z "$PKG_CONFIG"; then
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+ fi
+ if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
+ have_gtk_doc=yes
+ fi
+
+ dnl do we want to do a version check?
+ifelse([$1],[],,
+ [gtk_doc_min_version=$1
+ if test "$have_gtk_doc" = yes; then
+ AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
+ if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ have_gtk_doc=no
+ fi
+ fi
+])
+ if test "$have_gtk_doc" != yes; then
+ enable_gtk_doc=no
+ fi
+ fi
+
+ AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
+])