summaryrefslogtreecommitdiffstats
path: root/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb')
-rw-r--r--recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb b/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb
new file mode 100644
index 0000000000..28888c45ba
--- /dev/null
+++ b/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GTK theme engine Smooth"
+SECTION = "x11/base"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "gtk+"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/smooth-engine/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}