summaryrefslogtreecommitdiffstats
path: root/recipes/gtk-engines
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtk-engines')
-rw-r--r--recipes/gtk-engines/gtk-clearlooks-engine_0.6.2.bb24
-rw-r--r--recipes/gtk-engines/gtk-engines_2.15.4.bb30
-rw-r--r--recipes/gtk-engines/gtk-engines_2.6.5.bb32
-rw-r--r--recipes/gtk-engines/gtk-engines_2.7.4.bb32
-rw-r--r--recipes/gtk-engines/gtk-industrial-engine/no-gtk1.patch31
-rw-r--r--recipes/gtk-engines/gtk-industrial-engine_0.2.46.0.bb21
-rw-r--r--recipes/gtk-engines/gtk-sato-engine.inc19
-rw-r--r--recipes/gtk-engines/gtk-sato-engine_0.3.1.bb6
-rw-r--r--recipes/gtk-engines/gtk-sato-engine_svn.bb9
-rw-r--r--recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb22
10 files changed, 226 insertions, 0 deletions
diff --git a/recipes/gtk-engines/gtk-clearlooks-engine_0.6.2.bb b/recipes/gtk-engines/gtk-clearlooks-engine_0.6.2.bb
new file mode 100644
index 0000000000..1b009b5380
--- /dev/null
+++ b/recipes/gtk-engines/gtk-clearlooks-engine_0.6.2.bb
@@ -0,0 +1,24 @@
+SECTION = "x11/base"
+DESCRIPTION = "Clearlooks theme engine for GTK"
+LICENSE = "GPLv2"
+DEPENDS = "gtk+"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/clearlooks/clearlooks-0.6.2.tar.bz2"
+
+S = "${WORKDIR}/clearlooks-${PV}"
+
+PACKAGES += "gtk-theme-clearlooks"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/*/engines/.debug/*"
+FILES_gtk-theme-clearlooks = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+
diff --git a/recipes/gtk-engines/gtk-engines_2.15.4.bb b/recipes/gtk-engines/gtk-engines_2.15.4.bb
new file mode 100644
index 0000000000..177c5b8baf
--- /dev/null
+++ b/recipes/gtk-engines/gtk-engines_2.15.4.bb
@@ -0,0 +1,30 @@
+LICENSE = "GPL"
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+DEPENDS = "gtk+ cairo"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+RDEPENDS_gtk-theme-clearlooks = "gtk-engine-clearlooks"
+
+inherit gnome gtk-binver
+
+PACKAGES_DYNAMIC = "gtk-engine-* gtk-theme-*"
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
+
diff --git a/recipes/gtk-engines/gtk-engines_2.6.5.bb b/recipes/gtk-engines/gtk-engines_2.6.5.bb
new file mode 100644
index 0000000000..0dc9a95ecc
--- /dev/null
+++ b/recipes/gtk-engines/gtk-engines_2.6.5.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "GTK theme engines"
+SECTION = "x11/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+PR = "r1"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.6/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig gtk-binver
+
+PACKAGES_DYNAMIC = "gtk-engine-* gtk-theme-*"
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
diff --git a/recipes/gtk-engines/gtk-engines_2.7.4.bb b/recipes/gtk-engines/gtk-engines_2.7.4.bb
new file mode 100644
index 0000000000..7ad1acc0ca
--- /dev/null
+++ b/recipes/gtk-engines/gtk-engines_2.7.4.bb
@@ -0,0 +1,32 @@
+LICENSE = "GPL"
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+DEPENDS = "gtk+ cairo"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+RDEPENDS_gtk-theme-clearlooks = "gtk-engine-clearlooks"
+
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.7/${P}.tar.bz2"
+
+inherit autotools pkgconfig gtk-binver
+
+PACKAGES_DYNAMIC = "gtk-engine-* gtk-theme-*"
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
+
diff --git a/recipes/gtk-engines/gtk-industrial-engine/no-gtk1.patch b/recipes/gtk-engines/gtk-industrial-engine/no-gtk1.patch
new file mode 100644
index 0000000000..ad3d681694
--- /dev/null
+++ b/recipes/gtk-engines/gtk-industrial-engine/no-gtk1.patch
@@ -0,0 +1,31 @@
+--- gtk-industrial-engine-0.2.36.2/configure.ac.old 2004-11-28 16:48:45.000000000 +0000
++++ gtk-industrial-engine-0.2.36.2/configure.ac 2004-11-28 16:48:54.000000000 +0000
+@@ -27,11 +27,6 @@
+ AC_SUBST(GTK2_LIBS)
+ AC_SUBST(GTK2_VERSION)
+
+-AM_PATH_GTK(1.2.9, ,
+- AC_MSG_ERROR([*** GTK+-1.2.9 not installed - please install first ***]))AC_CHECK_LIB(gtk, gtk_style_set_prop_experimental, :,
+- AC_MSG_ERROR([*** gtk_style_set_prop_experimental() not found; perhaps you have an old CVS version of GTK+ ***]),
+- $GTK_LIBS)
+-
+ AC_CONFIG_FILES([
+ Makefile
+ icons/24x24/apps/Makefile
+@@ -56,8 +51,6 @@
+ icons/192x192/apps/Makefile
+ icons/192x192/filesystems/Makefile
+ icons/192x192/Makefile
+-gtk1-engine/Makefile
+-gtk1-engine/gtk/Makefile
+ gtk2-engine/Makefile
+ gtk2-engine/gtk-2.0/Makefile
+ gtk2-engine/gtk-2.0/gtkrc
+--- gtk-industrial-engine-0.2.36.2/Makefile.am.old 2004-11-28 16:49:02.000000000 +0000
++++ gtk-industrial-engine-0.2.36.2/Makefile.am 2004-11-28 16:49:08.000000000 +0000
+@@ -1,4 +1,4 @@
+-SUBDIRS = icons gtk1-engine gtk2-engine metacity po
++SUBDIRS = icons gtk2-engine metacity po
+
+ THEME_IN_FILES=index.theme.in
+
diff --git a/recipes/gtk-engines/gtk-industrial-engine_0.2.46.0.bb b/recipes/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
new file mode 100644
index 0000000000..d6e6de5037
--- /dev/null
+++ b/recipes/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
@@ -0,0 +1,21 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+LICENSE = "GPLv2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+ file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+
diff --git a/recipes/gtk-engines/gtk-sato-engine.inc b/recipes/gtk-engines/gtk-sato-engine.inc
new file mode 100644
index 0000000000..5ac690d630
--- /dev/null
+++ b/recipes/gtk-engines/gtk-sato-engine.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Sato theme engine for GTK"
+SECTION = "x11/base"
+LICENSE = "LGPL"
+DEPENDS = "gtk+"
+RDEPENDS_gtk-theme-sato = "gtk-sato-engine"
+
+PACKAGES += "gtk-theme-sato"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so "
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_${PN}-dbg = "${libdir}/gtk-2.0/*/engines/.debug"
+FILES_gtk-theme-sato = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
diff --git a/recipes/gtk-engines/gtk-sato-engine_0.3.1.bb b/recipes/gtk-engines/gtk-sato-engine_0.3.1.bb
new file mode 100644
index 0000000000..2b12d2d9e8
--- /dev/null
+++ b/recipes/gtk-engines/gtk-sato-engine_0.3.1.bb
@@ -0,0 +1,6 @@
+require gtk-sato-engine.inc
+
+PR = "r4"
+
+SRC_URI = "http://pokylinux.org/releases/sato/sato-engine-${PV}.tar.gz"
+S = "${WORKDIR}/sato-engine-${PV}"
diff --git a/recipes/gtk-engines/gtk-sato-engine_svn.bb b/recipes/gtk-engines/gtk-sato-engine_svn.bb
new file mode 100644
index 0000000000..6fbb7ccdbc
--- /dev/null
+++ b/recipes/gtk-engines/gtk-sato-engine_svn.bb
@@ -0,0 +1,9 @@
+require gtk-sato-engine.inc
+
+PV = "0.3.1+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/sato/trunk;module=gtk-engine;proto=http"
+
+EXTRA_OECONF += "${@base_contains('MACHINE_FEATURES', 'qvga', '--with-mode=qvga', '',d)}"
+
+S = "${WORKDIR}/gtk-engine"
diff --git a/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb b/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb
new file mode 100644
index 0000000000..28888c45ba
--- /dev/null
+++ b/recipes/gtk-engines/gtk-smooth-engine_0.5.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GTK theme engine Smooth"
+SECTION = "x11/base"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "gtk+"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/smooth-engine/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}