aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtksourceview
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gtksourceview')
-rw-r--r--recipes/gtksourceview/gtksourceview2_2.7.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/gtksourceview/gtksourceview2_2.7.3.bb b/recipes/gtksourceview/gtksourceview2_2.7.3.bb
new file mode 100644
index 0000000000..474b317678
--- /dev/null
+++ b/recipes/gtksourceview/gtksourceview2_2.7.3.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Portable C library for multiline text editing"
+HOMEPAGE = "http://projects.gnome.org/gtksourceview/"
+LICENSE = "LGPL"
+DEPENDS = "gtk+ libgnomeprint"
+PR = "r0"
+PNAME = "gtksourceview"
+
+S = "${WORKDIR}/${PNAME}-${PV}"
+
+inherit gnome pkgconfig
+
+# overrule SRC_URI from gnome.conf
+SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2"
+
+do_configure_prepend() {
+ sed -i -e s:docs::g ${S}/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += " ${datadir}/gtksourceview-2.0"
+