aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/guichan/guichan_0.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/guichan/guichan_0.7.1.bb')
-rw-r--r--recipes/guichan/guichan_0.7.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/guichan/guichan_0.7.1.bb b/recipes/guichan/guichan_0.7.1.bb
new file mode 100644
index 0000000000..83a9eca2c5
--- /dev/null
+++ b/recipes/guichan/guichan_0.7.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A portable C++ GUI library designed for games using Allegro, HGE, OpenGL, OpenLayer and/or SDL."
+HOMEPAGE = "http://guichan.sourceforge.net"
+DEPENDS = "virtual/libsdl libsdl-image"
+PR = "r1"
+
+SRC_URI = "http://guichan.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://link-against-sdlimage.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-opengl --disable-glut --disable-allegro \
+ --enable-sdlimage --enable-sdl"
+
+PACKAGES =+ "libguichan libguichan-sdl"
+
+FILES_libguichan = "${libdir}/libguichan.so.*"
+FILES_libguichan-sdl = "${libdir}/libguichan_sdl.so.*"
+
+do_stage () {
+ autotools_stage_all
+}
+