aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gzip
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gzip')
-rw-r--r--recipes/gzip/gzip-1.3.5/configure.patch30
-rw-r--r--recipes/gzip/gzip_1.3.5.bb36
2 files changed, 66 insertions, 0 deletions
diff --git a/recipes/gzip/gzip-1.3.5/configure.patch b/recipes/gzip/gzip-1.3.5/configure.patch
new file mode 100644
index 0000000000..64e901a9a4
--- /dev/null
+++ b/recipes/gzip/gzip-1.3.5/configure.patch
@@ -0,0 +1,30 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- gzip-1.3.5/./configure.in~configure
++++ gzip-1.3.5/./configure.in
+@@ -18,8 +18,8 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ # 02111-1307, USA.
+
+-AC_PREREQ(2.54)
+-AC_INIT(gzip, 1.3.5, bug-gzip@gnu.org)
++AC_PREREQ(2.57)
++AC_INIT([gzip],[1.3.5],[bug-gzip@gnu.org])
+ AC_CONFIG_SRCDIR(gzip.c)
+ AM_INIT_AUTOMAKE
+
+@@ -39,9 +39,8 @@
+
+ AC_CACHE_CHECK([for underline in external names], [gzip_cv_underline],
+ [gzip_cv_underline=yes
+- AC_TRY_COMPILE([int foo() {return 0;}], [],
+- [nm conftest.$OBJEXT | grep _foo >/dev/null 2>&1 ||
+- gzip_cv_underline=no])])
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[int foo() {return 0;}]], [[]])],[nm conftest.$OBJEXT | grep _foo >/dev/null 2>&1 ||
++ gzip_cv_underline=no],[])])
+ if test $gzip_cv_underline = no; then
+ ASCPP="${ASCPP} -DNO_UNDERLINE"
+ fi
diff --git a/recipes/gzip/gzip_1.3.5.bb b/recipes/gzip/gzip_1.3.5.bb
new file mode 100644
index 0000000000..a0c49864b4
--- /dev/null
+++ b/recipes/gzip/gzip_1.3.5.bb
@@ -0,0 +1,36 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+PRIORITY = "required"
+DESCRIPTION = "gzip (GNU zip) is a compression utility designed \
+to be a replacement for 'compress'. The GNU Project uses it as \
+the standard compression program for its system."
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gzip/gzip_${PV}.orig.tar.gz \
+ file://configure.patch;patch=1"
+
+S = "${WORKDIR}/gzip-${PV}"
+
+inherit autotools
+
+do_install () {
+ autotools_do_install
+ # Rename and move files into /bin (FHS)
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip.${PN}
+ mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip.${PN}
+ mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/gunzip gunzip gunzip.${PN} 100
+ update-alternatives --install ${base_bindir}/gzip gzip gzip.${PN} 100
+ update-alternatives --install ${base_bindir}/zcat zcat zcat.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove gunzip gunzip.${PN}
+ update-alternatives --remove gzip gzip.${PN}
+ update-alternatives --remove zcat zcat.${PN}
+}
+