summaryrefslogtreecommitdiffstats
path: root/recipes/h2200-bootloader
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/h2200-bootloader')
-rw-r--r--recipes/h2200-bootloader/h2200-bootloader.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/h2200-bootloader/h2200-bootloader.bb b/recipes/h2200-bootloader/h2200-bootloader.bb
new file mode 100644
index 0000000000..5db3cd058d
--- /dev/null
+++ b/recipes/h2200-bootloader/h2200-bootloader.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Bootloader firmware extractor for the h2200 iPAQ"
+RRECOMMENDS_${PN} = "kernel-module-mtdblock"
+ALLOW_EMPTY = "1"
+PR = "r3"
+
+COMPATIBLE_MACHINE = "h2200"
+#it is a shell script, but lets protect the innocent some more
+PACKAGE_ARCH = "h2200"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p /lib/firmware
+modprobe mtdblock
+dd if=/dev/mtdblock0 of=/lib/firmware/h2200_bootloader.bin 2>/dev/null
+}