aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal/hal_0.5.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hal/hal_0.5.12.bb')
-rw-r--r--recipes/hal/hal_0.5.12.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes/hal/hal_0.5.12.bb b/recipes/hal/hal_0.5.12.bb
new file mode 100644
index 0000000000..b6531e8235
--- /dev/null
+++ b/recipes/hal/hal_0.5.12.bb
@@ -0,0 +1,11 @@
+require hal.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+# The following code finds the right linux/input.h,
+# which also works with external-toolchain/SDK
+do_configure() {
+ linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
+ grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
+ autotools_do_configure --with-linux-input-header=${linux_input_h}
+}