summaryrefslogtreecommitdiffstats
path: root/recipes/hal/hal_0.5.14+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hal/hal_0.5.14+git.bb')
-rw-r--r--recipes/hal/hal_0.5.14+git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/hal/hal_0.5.14+git.bb b/recipes/hal/hal_0.5.14+git.bb
new file mode 100644
index 0000000000..dfbf60d11f
--- /dev/null
+++ b/recipes/hal/hal_0.5.14+git.bb
@@ -0,0 +1,24 @@
+require hal.inc
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+
+SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
+ file://20hal \
+ file://99_hal"
+
+SRCREV = "6dccf8e3ad181e8f56b1d2a994ec50a1953a1c2d"
+
+PV = "0.5.14"
+PR_append = "+gitr${SRCREV}"
+
+S = "${WORKDIR}/git"
+
+# The following code finds the right linux/input.h,
+# which also works with external-toolchain/SDK
+do_configure() {
+ sed -i -e s:1.43:1.41:g ${S}/configure.in
+ linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
+ grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
+ autotools_do_configure --with-linux-input-header=${linux_input_h}
+}