aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/helloworld/helloworld_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/helloworld/helloworld_1.0.0.bb')
-rw-r--r--recipes/helloworld/helloworld_1.0.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/helloworld/helloworld_1.0.0.bb b/recipes/helloworld/helloworld_1.0.0.bb
index af29a7769a..83b3965960 100644
--- a/recipes/helloworld/helloworld_1.0.0.bb
+++ b/recipes/helloworld/helloworld_1.0.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Minimal statically compiled Hello world!"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
S = "${WORKDIR}/${P}"
@@ -11,7 +11,8 @@ do_fetch () {
}
do_compile () {
- ${CC} -o helloworld helloworld.c -static
+ ${CC} ${CFLAGS} -c -o helloworld.o helloworld.c
+ ${CC} ${LDFLAGS} -o helloworld helloworld.o -static
}
do_install () {