aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hsetroot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/hsetroot')
-rw-r--r--recipes/hsetroot/files/pkgconfigize-imlib.patch22
-rw-r--r--recipes/hsetroot/hsetroot_1.0.2.bb10
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes/hsetroot/files/pkgconfigize-imlib.patch b/recipes/hsetroot/files/pkgconfigize-imlib.patch
new file mode 100644
index 0000000000..862b74fad2
--- /dev/null
+++ b/recipes/hsetroot/files/pkgconfigize-imlib.patch
@@ -0,0 +1,22 @@
+Index: hsetroot-1.0.2/configure.ac
+===================================================================
+--- hsetroot-1.0.2.orig/configure.ac 2003-09-05 21:41:38.000000000 +0000
++++ hsetroot-1.0.2/configure.ac 2007-08-09 21:14:09.000000000 +0000
+@@ -39,16 +39,7 @@
+ AC_C_CONST
+
+ # Check for imlib2
+-AC_CHECK_PROGS(imlib2config_cmd, imlib2-config)
+-if test x$imlib2config_cmd = "x"; then
+- AC_MSG_ERROR([error. Imlib2 is required to compile.])
+-fi
+-
+-IMLIB2_CFLAGS=`$imlib2config_cmd --cflags`
+-AC_SUBST(IMLIB2_CFLAGS)
+-
+-IMLIB2_LIBS=`$imlib2config_cmd --libs`
+-AC_SUBST(IMLIB2_LIBS)
++PKG_CHECK_MODULES(IMLIB2, imlib2)
+
+ # Some extra definitions for config.h
+ AC_DEFINE(DESCRIPTION, "yet another wallpaper application", [single line package description])
diff --git a/recipes/hsetroot/hsetroot_1.0.2.bb b/recipes/hsetroot/hsetroot_1.0.2.bb
new file mode 100644
index 0000000000..64ff997b50
--- /dev/null
+++ b/recipes/hsetroot/hsetroot_1.0.2.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Yet another X Wallpaper Utility"
+DEPENDS += "imlib2 freetype zlib virtual/libx11 libxext"
+RDEPENDS += "imlib2-loaders"
+LICENSE = "GPL"
+
+SRC_URI = "http://thegraveyard.org/files/hsetroot-${PV}.tar.gz \
+ file://pkgconfigize-imlib.patch;patch=1"
+
+inherit autotools
+