aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/i2c-tools/picodlp-control_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/i2c-tools/picodlp-control_0.1.bb')
-rw-r--r--recipes/i2c-tools/picodlp-control_0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/i2c-tools/picodlp-control_0.1.bb b/recipes/i2c-tools/picodlp-control_0.1.bb
new file mode 100644
index 0000000000..5fb5630d87
--- /dev/null
+++ b/recipes/i2c-tools/picodlp-control_0.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Small application to control the pico DLP over I2C"
+LICENSE = "GPLv3"
+PR = "r3"
+
+SRC_URI = "file://*.c file://*.h file://${PN}"
+
+do_configure() {
+ cp ${WORKDIR}/*.[ch] ${WORKDIR}/${PN} ${S}
+}
+
+do_compile() {
+ ${CC} -o bus3-i2c *.c ${CFLAGS} ${LDFLAGS}
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/${PN} ${D}/${bindir}
+ install -m 0755 ${S}/bus3-i2c ${D}/${bindir}
+}
+