aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iaimaster/iaimaster_0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/iaimaster/iaimaster_0.5.bb')
-rw-r--r--recipes/iaimaster/iaimaster_0.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/iaimaster/iaimaster_0.5.bb b/recipes/iaimaster/iaimaster_0.5.bb
new file mode 100644
index 0000000000..e86cf361b4
--- /dev/null
+++ b/recipes/iaimaster/iaimaster_0.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Pen action mini game. You fight evil Iai-Master and must survive. \
+(Iai is a kind of the samurai fighting style)"
+SECTION = "opie/games"
+LICENSE = "GPL"
+APPNAME = "${PN}"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+SRC_URI = "http://www.urban.ne.jp/home/kanemori/zaurus/IaiMaster_${PV}.tar.gz \
+ file://iaimaster.desktop \
+ file://iaimaster.png"
+S = "${WORKDIR}/IaiMaster"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "TARGET=${PN}"
+
+do_configure_prepend() {
+ qmake -project
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/iaimaster.png ${D}${palmtopdir}/pics/
+}
+