aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ibrdtn
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ibrdtn')
-rw-r--r--recipes/ibrdtn/files/0001-fix-header-include-for-gcc44.patch22
-rw-r--r--recipes/ibrdtn/ibrdtn_0.1.1.bb17
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/ibrdtn/files/0001-fix-header-include-for-gcc44.patch b/recipes/ibrdtn/files/0001-fix-header-include-for-gcc44.patch
new file mode 100644
index 0000000000..c2024c05c5
--- /dev/null
+++ b/recipes/ibrdtn/files/0001-fix-header-include-for-gcc44.patch
@@ -0,0 +1,22 @@
+ibrdtn: Fix include for stricter GCC 4.4 header handling
+
+GCC 4.4 is stricter on its headers so we need to make sure the uint64_t is
+really available or the compiler errors out:
+src/data/BlockFactory.cpp:101: error: ‘uint64_t’ was not declared in this scope
+src/data/BlockFactory.cpp:101: error: expected ‘;’ before ‘i’
+src/data/BlockFactory.cpp:101: error: ‘i’ was not declared in this scope
+
+--
+
+Index: ibrdtn-0.1.1/src/data/BlockFactory.cpp
+===================================================================
+--- ibrdtn-0.1.1.orig/src/data/BlockFactory.cpp 2010-02-12 13:25:37.000000000 +0100
++++ ibrdtn-0.1.1/src/data/BlockFactory.cpp 2010-02-12 13:25:49.000000000 +0100
+@@ -5,6 +5,7 @@
+ * Author: morgenro
+ */
+
++#include <stdint.h>
+ #include "data/BlockFactory.h"
+ #include "data/SDNV.h"
+ #include "data/Exceptions.h"
diff --git a/recipes/ibrdtn/ibrdtn_0.1.1.bb b/recipes/ibrdtn/ibrdtn_0.1.1.bb
new file mode 100644
index 0000000000..90e9e43964
--- /dev/null
+++ b/recipes/ibrdtn/ibrdtn_0.1.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Implementation of the bundle protocol RFC5050"
+HOMEPAGE = "http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/"
+SECTION = "devel"
+DEPENDS = "libpthread-stubs sqlite3 lua5.1"
+PR = "r0"
+
+SRC_URI = "http://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases/ibrdtn-${PV}.tar.gz \
+ file://0001-fix-header-include-for-gcc44.patch;patch=1 \
+ "
+
+inherit autotools
+
+EXTRA_OECONF = "--prefix=${D} --exec-prefix=${D} --libdir=${STAGING_LIBDIR} --includedir=${STAGING_INCDIR}"
+
+do_configure() {
+ oe_runconf
+}