aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icommand/icommand-bluez_0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/icommand/icommand-bluez_0.7.bb')
-rw-r--r--recipes/icommand/icommand-bluez_0.7.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/icommand/icommand-bluez_0.7.bb b/recipes/icommand/icommand-bluez_0.7.bb
new file mode 100644
index 0000000000..70d78f02d0
--- /dev/null
+++ b/recipes/icommand/icommand-bluez_0.7.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "iCommand bluez binding"
+LICENSE = "LGPL"
+SECTION = "libs"
+HOMEPAGE = "http://sourceforge.net/projects/nxtcommand/"
+AUTHOR = "Brian Bagnall <bbagnall at users.sourceforge.net>"
+
+inherit java
+
+SRC_URI = "\
+ svn://nxtcommand.svn.sourceforge.net/svnroot/nxtcommand;module=icommand-projects/trunk/icommand-bluez;rev=134;proto=https \
+ file://makefile.patch;patch=1 \
+ "
+
+DEPENDS = "bluez-libs"
+
+S = "${WORKDIR}/icommand-projects/trunk/icommand-bluez/Release"
+
+do_compile() {
+ oe_runmake -f makefile clean
+ oe_runmake -f makefile all \
+ INCLUDES="-I${STAGING_INCDIR}/classpath " \
+ LIBS="-lbluetooth"
+}
+
+do_install() {
+ oe_libinstall -so libicmdbluez ${D}${libdir_jni}
+}
+
+PACKAGES = "${PN}-jni ${PN}-jni-dbg"
+
+RDEPENDS_${PN}-jni = "bluez-libs"
+
+FILES_${PN}-jni = "${libdir_jni}/lib*.so"
+FILES_${PN}-jni-dbg = "${libdir_jni}/.debug/lib*.so"