summaryrefslogtreecommitdiffstats
path: root/recipes/imagemagick
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/imagemagick')
-rw-r--r--recipes/imagemagick/files/fix_open_file.patch12
-rw-r--r--recipes/imagemagick/imagemagick_6.3.5-10.bb5
2 files changed, 15 insertions, 2 deletions
diff --git a/recipes/imagemagick/files/fix_open_file.patch b/recipes/imagemagick/files/fix_open_file.patch
new file mode 100644
index 0000000000..8374e1e551
--- /dev/null
+++ b/recipes/imagemagick/files/fix_open_file.patch
@@ -0,0 +1,12 @@
+diff -rup ImageMagick-6.3.5.orig/magick/delegate.c ImageMagick-6.3.5/magick/delegate.c
+--- ImageMagick-6.3.5.orig/magick/delegate.c 2009-10-15 18:40:06.000000000 +0200
++++ ImageMagick-6.3.5/magick/delegate.c 2009-10-15 18:23:10.000000000 +0200
+@@ -769,7 +769,7 @@ static void CopyDelegateFile(const char
+ /*
+ Copy source file to destination.
+ */
+- destination_file=open(destination,O_WRONLY | O_BINARY | O_CREAT);
++ destination_file=open(destination, O_BINARY | O_CREAT, O_WRONLY);
+ if (destination_file == -1)
+ return;
+ source_file=open(source,O_RDONLY | O_BINARY);
diff --git a/recipes/imagemagick/imagemagick_6.3.5-10.bb b/recipes/imagemagick/imagemagick_6.3.5-10.bb
index cf9e82f3e2..8bd25e9d5a 100644
--- a/recipes/imagemagick/imagemagick_6.3.5-10.bb
+++ b/recipes/imagemagick/imagemagick_6.3.5-10.bb
@@ -2,12 +2,13 @@ DESCRIPTION = "ImageMagick is an image convertion tools"
SECTION = "console/utils"
LICENSE = "GPL"
DEPENDS = "tiff"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.nluug.nl/pub/ImageMagick/ImageMagick-${PV}.tar.bz2 \
file://PerlMagic_MakePatch;patch=1 \
file://makefile-am.patch;patch=1 \
- file://binconfig-fixes.patch;patch=1 "
+ file://binconfig-fixes.patch;patch=1 \
+ file://fix_open_file.patch;patch=1 "
IMVER = "6.3.5"