aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/console-at91sam9-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/console-at91sam9-image.bb')
-rw-r--r--recipes/images/console-at91sam9-image.bb33
1 files changed, 26 insertions, 7 deletions
diff --git a/recipes/images/console-at91sam9-image.bb b/recipes/images/console-at91sam9-image.bb
index 7aae0fb13e..aeb6ed5e6c 100644
--- a/recipes/images/console-at91sam9-image.bb
+++ b/recipes/images/console-at91sam9-image.bb
@@ -1,18 +1,23 @@
-#Angstrom bootstrap at91sam9 image
+#Angstrom basic console at91sam9 image
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
ANGSTROM_EXTRA_INSTALL += " \
- usbview \
- mplayer \
- thttpd \
- madplay \
- alsa-utils-aplay \
+ alsa-utils-alsamixer \
+ alsa-utils-alsactl \
alsa-utils-amixer \
- iperf \
+ alsa-utils-aplay \
+# bash-sh \
dosfstools \
+ iperf \
+ madplay \
mtd-utils \
+ mplayer \
# nbench-byte \
+# owl-wifi \
+# thttpd \
+ ttcp \
+# usbview \
"
DEPENDS = "task-base-extended \
@@ -30,5 +35,19 @@ IMAGE_LINGUAS = ""
#we dont need the kernel in the image
ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ # cd bin
+ # ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "
+
inherit image