summaryrefslogtreecommitdiffstats
path: root/recipes/images/console-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/console-image.bb')
-rw-r--r--recipes/images/console-image.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes/images/console-image.bb b/recipes/images/console-image.bb
index e30793b05f..9707881402 100644
--- a/recipes/images/console-image.bb
+++ b/recipes/images/console-image.bb
@@ -4,19 +4,21 @@ IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
ANGSTROM_EXTRA_INSTALL ?= ""
-SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
+SPLASH ?= ""
+ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
DEPENDS = "task-base-extended \
${SPLASH} \
+ ${ZZAPSPLASH} \
"
IMAGE_INSTALL = "task-base-extended \
${ANGSTROM_EXTRA_INSTALL} \
${SPLASH} \
- "
+ ${ZZAPSPLASH} \
+ "
export IMAGE_BASENAME = "console-image"
IMAGE_LINGUAS = ""
inherit image
-