aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/gateway-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/gateway-image.bb')
-rw-r--r--recipes/images/gateway-image.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/images/gateway-image.bb b/recipes/images/gateway-image.bb
new file mode 100644
index 0000000000..ee9d1d97fc
--- /dev/null
+++ b/recipes/images/gateway-image.bb
@@ -0,0 +1,20 @@
+#Angstrom gateway image
+#gives you a gateway with SMB, ssh and dnsmasqs
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+IMAGE_INSTALL = "task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ iptables \
+ samba swat \
+ dnsmasq \
+# vsftpd \
+ angstrom-version \
+ "
+
+export IMAGE_BASENAME = "gateway-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+