aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/initramfs-bootmenu-debug-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/initramfs-bootmenu-debug-image.bb')
-rw-r--r--recipes/images/initramfs-bootmenu-debug-image.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/images/initramfs-bootmenu-debug-image.bb b/recipes/images/initramfs-bootmenu-debug-image.bb
new file mode 100644
index 0000000000..df5bf2b6c0
--- /dev/null
+++ b/recipes/images/initramfs-bootmenu-debug-image.bb
@@ -0,0 +1,16 @@
+# initramfs image with interactive boot menu allowing to select rootfs location
+# from choices of block devices, loopback images and NFS.
+
+IMAGE_INSTALL = "busybox-static initramfs-module-bootmenu initramfs-module-check-modules initramfs-module-kexecboot klibc-utils-static-modprobe"
+IMAGE_INSTALL += " dropbear dropbear-backdoor"
+IMAGE_LINGUAS = ""
+
+
+# Remove any kernel-image that the kernel-module-* packages may have pulled in.
+PACKAGE_REMOVE = "kernel-image-* update-modules module-init-tools-depmod update-rc.d"
+ROOTFS_POSTPROCESS_COMMAND += "opkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+IMAGE_FSTYPES += " cpio.gz "
+
+inherit image