aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/liveramdisk-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/liveramdisk-image.bb')
-rw-r--r--recipes/images/liveramdisk-image.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/images/liveramdisk-image.bb b/recipes/images/liveramdisk-image.bb
new file mode 100644
index 0000000000..5caa4baa11
--- /dev/null
+++ b/recipes/images/liveramdisk-image.bb
@@ -0,0 +1,22 @@
+# LiveRamdisk image
+# Building with ANGSTROMLIBC=uclibc is recommended
+#
+# LiveRamdisk concept/implementation by Paul Sokolovsky
+LICENSE = "MIT"
+IMAGE_FSTYPES = "cpio.gz"
+
+#IMAGE_INSTALL = "initramfs-boot busybox kernel-module-uinput uclibc libgcc1"
+IMAGE_INSTALL = "initramfs-jffs2 busybox-static kernel-module-mtdram"
+
+export IMAGE_BASENAME = "liveramdisk"
+export IMAGE_LINGUAS = ""
+
+# Install only ${IMAGE_INSTALL}, not even deps
+#PACKAGE_INSTALL_NO_DEPS = "1"
+
+# Remove any kernel-image that the kernel-module-* packages may have pulled in.
+PACKAGE_REMOVE = "kernel-image-* update-modules module-init-tools-depmod uclibc update-rc.d"
+ROOTFS_POSTPROCESS_COMMAND += "opkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+inherit image