summaryrefslogtreecommitdiffstats
path: root/recipes/images/minimal-gpe-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/minimal-gpe-image.bb')
-rw-r--r--recipes/images/minimal-gpe-image.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/images/minimal-gpe-image.bb b/recipes/images/minimal-gpe-image.bb
new file mode 100644
index 0000000000..5dd08f6e23
--- /dev/null
+++ b/recipes/images/minimal-gpe-image.bb
@@ -0,0 +1,25 @@
+#Angstrom minimal gpe image
+# This image provides a barebone dm and 'desktop'
+# Very angstrom and opkg centric
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+export IMAGE_BASENAME = "minimalist-gpe-image"
+
+PR = "r2"
+
+DEPENDS = "task-boot"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ task-boot \
+ gpe-dm gpe-session-scripts gpe-login \
+ matchbox-wm \
+ gpe-terminal \
+ angstrom-feed-configs \
+ opkg-nogpg opkg-collateral \
+ "
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image