aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/sectest-gpe-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/sectest-gpe-image.bb')
-rw-r--r--recipes/images/sectest-gpe-image.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/images/sectest-gpe-image.bb b/recipes/images/sectest-gpe-image.bb
new file mode 100644
index 0000000000..6249afa8cc
--- /dev/null
+++ b/recipes/images/sectest-gpe-image.bb
@@ -0,0 +1,30 @@
+GPE_EXTRA_THEMES = "\
+ gtk-theme-industrial \
+ gtk-industrial-engine \
+ matchbox-themes-extra-industrial"
+
+GPE_EXTRA_INSTALL_none = ""
+GPE_EXTRA_INSTALL_smallscreen = "${GPE_EXTRA_THEMES}"
+GPE_EXTRA_INSTALL_bigscreen = "minimo gpe-task-games ${GPE_EXTRA_THEMES}"
+#GPE_EXTRA_INSTALL_bigscreen = "firefox linphone"
+
+GUI_MACHINE_CLASS ?= "none"
+GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+DEPENDS = "${MACHINE_TASK_PROVIDER} task-gpe"
+
+IMAGE_INSTALL = "\
+ ${MACHINE_TASK_PROVIDER} \
+ gpe-task-base \
+ gpe-task-pim \
+ gpe-task-settings \
+ gpe-task-sectest \
+ ${XSERVER} \
+ ${GPE_EXTRA_INSTALL}"
+
+ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+
+inherit image
+