aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/x11-at91sam9-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/x11-at91sam9-image.bb')
-rw-r--r--recipes/images/x11-at91sam9-image.bb63
1 files changed, 21 insertions, 42 deletions
diff --git a/recipes/images/x11-at91sam9-image.bb b/recipes/images/x11-at91sam9-image.bb
index d0ca0b64b6..55e1976b9f 100644
--- a/recipes/images/x11-at91sam9-image.bb
+++ b/recipes/images/x11-at91sam9-image.bb
@@ -1,20 +1,13 @@
# Angstrom x11-gpe-image with additional apps included
XSERVER = "xserver-xorg \
xf86-input-evdev \
- xf86-input-mouse \
- xf86-video-fbdev \
- xf86-input-keyboard \
- xinput-calibrator \
- "
-# xf86-input-tslib \
-
+ xf86-input-tslib \
+ xf86-video-fbdev "
require x11-gpe-image.bb
export IMAGE_BASENAME = "x11-at91sam9-image"
-# SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
-
DEPENDS = "task-base"
IMAGE_INSTALL += "\
@@ -38,57 +31,43 @@ IMAGE_INSTALL += "\
matchbox-panel-hacks \
usbview \
mplayer \
- thttpd \
madplay \
alsa-utils-aplay \
alsa-utils-amixer \
+ alsa-utils-alsamixer \
+ alsa-utils-alsactl \
iperf \
fbv \
dosfstools \
mtd-utils \
-# gpe-mini-browser2 \
+ bash-sh \
tslib-conf \
tslib-calibrate \
tslib-tests \
libstdc++ \
- nano \
-# nbench-byte \
pointercal \
- gstreamer \
- gst-plugins-base \
- gst-plugins-good \
- gst-plugins-bad \
- gst-plugins-ugly \
- gst-plugin-avi \
- gst-plugin-mpegstream \
- gst-plugin-qtdemux \
- gst-plugin-mpegvideoparse \
- gst-plugin-asf \
- gst-plugin-alsa \
- gst-plugin-ossaudio \
- gst-plugin-audioresample \
- gst-plugin-audioconvert \
- gst-plugin-ximagesink \
- gst-plugin-fbdevsink \
- gst-plugin-faad \
- gst-plugin-mad \
- gst-plugin-playbin \
- gst-plugin-decodebin \
- gst-plugin-typefindfunctions \
- gst-ffmpeg \
-# gst-plugin-on2-8170 \
-# on2-8170-libs \
- owl-wifi \
+# ${IMAGE_EXTRA_INSTALL} \
+# gpe-mini-browser \
+# nbench-byte \
"
-IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-
# IMAGE_LINGUAS += " se no dk fi"
-#zap root password for release images
-ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
ROOTFS_POSTPROCESS_COMMAND += "set_image_autologin; "
ROOTFS_POSTPROCESS_COMMAND += "install_linguas; "
#we dont need the kernel in the image
ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+at91sam9_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # bash-sh: pkg_postinst_bash command shall be run again
+ # (overloaded by busybox shell)
+ cd bin
+ ln -sf bash sh
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9_rootfs_postprocess; "