aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/x11-pimlico-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/x11-pimlico-image.bb')
-rw-r--r--recipes/images/x11-pimlico-image.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/images/x11-pimlico-image.bb b/recipes/images/x11-pimlico-image.bb
new file mode 100644
index 0000000000..79dcacce6e
--- /dev/null
+++ b/recipes/images/x11-pimlico-image.bb
@@ -0,0 +1,26 @@
+#Angstrom X11 image, with apps and kernel modules included
+
+ANGSTROM_EXTRA_INSTALL += " \
+ "
+XSERVER ?= "xserver-kdrive-fbdev"
+
+export IMAGE_BASENAME = "x11-pimlico-image"
+
+DEPENDS = "task-base"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ task-base-extended \
+ angstrom-x11-base-depends \
+ angstrom-gpe-task-base \
+ angstrom-gpe-task-settings \
+ kernel-modules \
+ hal \
+ angstrom-ohand-task-pim \
+ ${ANGSTROM_EXTRA_INSTALL}"
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image