aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/xfce-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/xfce-image.bb')
-rw-r--r--recipes/images/xfce-image.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/images/xfce-image.bb b/recipes/images/xfce-image.bb
new file mode 100644
index 0000000000..70c183c897
--- /dev/null
+++ b/recipes/images/xfce-image.bb
@@ -0,0 +1,16 @@
+export IMAGE_BASENAME = "xfce-image"
+
+IMAGE_LINGUAS = ""
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+X_DEPENDS = "virtual/xserver"
+X_RDEPENDS = "${XSERVER}"
+
+XFCE_DEPENDS = "${MACHINE_TASK_PROVIDER} task-xfce-base"
+XFCE_RDEPENDS = "${XFCE_DEPENDS}"
+
+IMAGE_INSTALL = "${X_RDEPENDS} ${XFCE_RDEPENDS}"
+DEPENDS = "${X_DEPENDS} ${XFCE_DEPENDS}"
+
+inherit image