aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/james-image.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/images/james-image.bb b/recipes/images/james-image.bb
new file mode 100644
index 0000000000..7d75c13c8d
--- /dev/null
+++ b/recipes/images/james-image.bb
@@ -0,0 +1,37 @@
+# James image
+
+inherit image
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+IMAGE_INSTALL += "task-boot \
+ task-nas-server-everything \
+ task-mythtv \
+ task-internetserver \
+ task-mediaserver \
+ task-importmedia \
+# stuff below needs a proper task
+ dropbear \
+ xinetd \
+ util-linux-ng-mount util-linux-ng-umount \
+ screen \
+ cups procps\
+ xmltv \
+ midori \
+ lame \
+ cwiid \
+ w3cam \
+ "
+
+# the following packages still need some work and will (maybe?)
+# be added in due time
+# motion \
+# asterisk \
+# ekiga \
+# lcd4linux \
+# mplayer \
+
+export IMAGE_BASENAME = "james-image"
+IMAGE_LINGUAS = ""
+
+