aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/angstrom-gnome-image.bb3
-rw-r--r--recipes/images/angstrom-systemd-image.bb19
-rw-r--r--recipes/images/aurora-fb-image.bb15
-rw-r--r--recipes/images/aurora-image.inc24
-rw-r--r--recipes/images/beagleboard-nand-image.bb2
-rw-r--r--recipes/images/beagleboard-validation-gnome-image.bb4
-rw-r--r--recipes/images/console-at91sam9-image.bb13
-rw-r--r--recipes/images/fso-illume-image.bb5
-rw-r--r--recipes/images/fso-image.inc3
-rw-r--r--recipes/images/illume-image.bb14
-rw-r--r--recipes/images/nylon-image-base.bb39
-rw-r--r--recipes/images/nylon-image-extended.bb84
-rw-r--r--recipes/images/nylon-image-extra.bb9
-rw-r--r--recipes/images/nylon-image-mini.bb14
-rw-r--r--recipes/images/nylon-image-standard.bb26
-rw-r--r--recipes/images/shr-image.inc18
-rw-r--r--recipes/images/x11-at91sam9-image.bb46
-rw-r--r--recipes/images/x11-at91sam9m10-image.bb102
-rw-r--r--recipes/images/x11-sato2-image.bb29
19 files changed, 270 insertions, 199 deletions
diff --git a/recipes/images/angstrom-gnome-image.bb b/recipes/images/angstrom-gnome-image.bb
index 3917088c86..8c925b295a 100644
--- a/recipes/images/angstrom-gnome-image.bb
+++ b/recipes/images/angstrom-gnome-image.bb
@@ -13,7 +13,7 @@ XSERVER ?= "xserver-xorg \
export IMAGE_BASENAME = "GNOME-image"
IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
-ROOTFS_POSTPROCESS_COMMAND += 'install_linguas;'
+ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
IMAGE_LOGIN_MANAGER = "shadow"
@@ -22,6 +22,7 @@ IMAGE_SPLASH = "psplash-angstrom"
ANGSTROM_EXTRA_INSTALL ?= ""
IMAGE_INSTALL += " \
+ linux-firmware-wl12xx \
task-base-extended \
${ANGSTROM_EXTRA_INSTALL} \
${IMAGE_SPLASH} \
diff --git a/recipes/images/angstrom-systemd-image.bb b/recipes/images/angstrom-systemd-image.bb
new file mode 100644
index 0000000000..9e2133522b
--- /dev/null
+++ b/recipes/images/angstrom-systemd-image.bb
@@ -0,0 +1,19 @@
+#Angstrom image to test systemd
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+IMAGE_INSTALL = " \
+ busybox \
+ bash-sh \
+ dropbear \
+ e2fsprogs-e2fsck \
+ avahi-daemon avahi-utils \
+ connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi"
+
+IMAGE_DEV_MANAGER = "udev"
+IMAGE_INIT_MANAGER = "systemd"
+IMAGE_INITSCRIPTS = " "
+IMAGE_LOGIN_MANAGER = "tinylogin shadow"
+
+
+inherit image
diff --git a/recipes/images/aurora-fb-image.bb b/recipes/images/aurora-fb-image.bb
new file mode 100644
index 0000000000..a561394236
--- /dev/null
+++ b/recipes/images/aurora-fb-image.bb
@@ -0,0 +1,15 @@
+###############################################################################
+# Aurora Framebuffer Image
+###############################################################################
+
+require aurora-image.inc
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+export IMAGE_BASENAME = "aurora-fb-image"
+
+IMAGE_INSTALL += " \
+ task-qt4e-base \
+ ${TOUCH} \
+ pointercal \
+"
diff --git a/recipes/images/aurora-image.inc b/recipes/images/aurora-image.inc
new file mode 100644
index 0000000000..86289a5e6d
--- /dev/null
+++ b/recipes/images/aurora-image.inc
@@ -0,0 +1,24 @@
+###############################################################################
+# Aurora Base Image
+###############################################################################
+
+PV = "0.1"
+
+IMAGE_DEBUG_APPEND = '${@base_conditional("DISTRO_TYPE", "debug", "gdb strace mdbus2", "",d)}'
+
+IMAGE_INSTALL = " \
+ task-base \
+ task-cli-tools \
+ task-cli-tools-python \
+ task-fso2-compliance \
+ \
+ ttf-ubuntu-sans \
+ aurora \
+ \
+ ${IMAGE_DEBUG_APPEND} \
+"
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+export IMAGE_BASENAME = "aurora-image"
+
+inherit image
+
diff --git a/recipes/images/beagleboard-nand-image.bb b/recipes/images/beagleboard-nand-image.bb
index 28cfec52b4..a5a22ebf5e 100644
--- a/recipes/images/beagleboard-nand-image.bb
+++ b/recipes/images/beagleboard-nand-image.bb
@@ -19,6 +19,8 @@ IMAGE_INSTALL = "\
${XSERVER} \
${ANGSTROM_EXTRA_INSTALL} \
task-beagleboard-nand \
+ linux-firmware-wl12xx \
+ iw \
${SPLASH} \
"
diff --git a/recipes/images/beagleboard-validation-gnome-image.bb b/recipes/images/beagleboard-validation-gnome-image.bb
index f82c6ca346..5341a28257 100644
--- a/recipes/images/beagleboard-validation-gnome-image.bb
+++ b/recipes/images/beagleboard-validation-gnome-image.bb
@@ -22,12 +22,12 @@ IMAGE_SPLASH = "psplash-angstrom"
ANGSTROM_EXTRA_INSTALL ?= ""
IMAGE_INSTALL += " \
- task-omap-drivers \
- task-base-extended \
+ task-beagleboard-validation-base \
${ANGSTROM_EXTRA_INSTALL} \
${IMAGE_SPLASH} \
angstrom-task-gnome \
angstrom-gdm-autologin-hack \
bash-sh \
+ midori gedit \
"
diff --git a/recipes/images/console-at91sam9-image.bb b/recipes/images/console-at91sam9-image.bb
index 8b066e283f..7aae0fb13e 100644
--- a/recipes/images/console-at91sam9-image.bb
+++ b/recipes/images/console-at91sam9-image.bb
@@ -3,17 +3,16 @@
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
ANGSTROM_EXTRA_INSTALL += " \
- alsa-utils-amixer \
+ usbview \
+ mplayer \
+ thttpd \
+ madplay \
alsa-utils-aplay \
- dosfstools \
+ alsa-utils-amixer \
iperf \
- madplay \
- mplayer \
+ dosfstools \
mtd-utils \
# nbench-byte \
- owl-wifi \
- thttpd \
- usbview \
"
DEPENDS = "task-base-extended \
diff --git a/recipes/images/fso-illume-image.bb b/recipes/images/fso-illume-image.bb
index 189c8cba69..d803aa2b9a 100644
--- a/recipes/images/fso-illume-image.bb
+++ b/recipes/images/fso-illume-image.bb
@@ -5,7 +5,7 @@
require fso-image.inc
PV = "1.1"
-PR = "r1"
+PR = "r2"
# no languages for now
IMAGE_LINGUAS = ""
@@ -14,7 +14,7 @@ BASE_INSTALL = "\
task-base \
"
-ILLUME_THEME = "illume-theme-fso"
+ETHEME = "illume-theme-fso"
X_INSTALL = "\
task-x11-illume \
@@ -35,7 +35,6 @@ TOOLS_INSTALL = "\
# audio
AUDIO_INSTALL = "\
alsa-oss \
- alsa-state \
alsa-utils-aplay \
alsa-utils-amixer \
gst-meta-audio \
diff --git a/recipes/images/fso-image.inc b/recipes/images/fso-image.inc
index 5311f84455..adce0e97a9 100644
--- a/recipes/images/fso-image.inc
+++ b/recipes/images/fso-image.inc
@@ -9,7 +9,7 @@ BASE_INSTALL = "\
task-base \
"
-ILLUME_THEME = "illume-theme-freesmartphone"
+ETHEME = "illume-theme-freesmartphone"
X_INSTALL = "\
task-x11-illume \
@@ -30,7 +30,6 @@ TOOLS_INSTALL = "\
# audio
AUDIO_INSTALL = "\
alsa-oss \
- alsa-state \
alsa-utils-aplay \
alsa-utils-amixer \
gst-meta-audio \
diff --git a/recipes/images/illume-image.bb b/recipes/images/illume-image.bb
index e01ef276ee..3f146c6b88 100644
--- a/recipes/images/illume-image.bb
+++ b/recipes/images/illume-image.bb
@@ -8,8 +8,10 @@ IMAGE_LINGUAS = "en-us de-de fr-fr pt-br ca-es zh-cn zh-tw bg-bg cs-cz da-dk nl-
SPLASH = "exquisite exquisite-themes exquisite-theme-illume"
# Default illume theme
-ILLUME_THEME ?= "e-wm-theme-illume"
-ILLUME_CONFIG ?= "e-wm-config-illume2"
+ETHEME ?= "e-wm-theme-illume"
+ECONFIG ?= "e-wm-config-illume2"
+ESYSACTIONS ?= "e-wm-sysactions"
+EMENU ?= "e-wm-menu"
# getting the base system up
BASE_INSTALL = "\
@@ -42,10 +44,10 @@ X_INSTALL = "\
shared-mime-info \
mime-support \
e-wm \
- e-wm-menu \
- e-wm-sysactions \
- ${ILLUME_CONFIG} \
- ${ILLUME_THEME} \
+ ${EMENU} \
+ ${ESYSACTIONS} \
+ ${ECONFIG} \
+ ${ETHEME} \
e-wm-config-standard \
e-wm-config-netbook \
e-wm-config-minimalist \
diff --git a/recipes/images/nylon-image-base.bb b/recipes/images/nylon-image-base.bb
deleted file mode 100644
index 416be1fae5..0000000000
--- a/recipes/images/nylon-image-base.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-inherit image
-inherit nylon-image
-
-IMAGE_FSTYPES = "jffs2 tar.gz"
-
-export IMAGE_BASENAME = "nylon-base"
-
-NYLON_BASE = "base-files base-passwd bash busybox \
- ipkg initscripts less \
- madwifi-modules \
- mtd-utils \
- nylon-scripts \
- nano ncurses netbase \
- openssh \
- pciutils \
- sysvinit \
- tinylogin \
- tzdata \
- wireless-tools wlan-ng-utils"
-
-DEPENDS += "virtual/kernel less nano"
-
-## kernel 2.4 ##
-NYLON_IMAGE_RDEPENDS_mtx-1 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
-NYLON_IMAGE_RDEPENDS_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
-## kernel 2.6 ##
-NYLON_IMAGE_RDEPENDS_mtx-3 = " module-init-tools udev"
-NYLON_IMAGE_RDEPENDS_mtx-3a = " module-init-tools"
-
-RDEPENDS_append = ${NYLON_IMAGE_RDEPENDS}
-
-IMAGE_INSTALL = "kernel less nano elvis-tiny \
- ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS} ${NYLON_IMAGE_RDEPENDS}"
-
-IMAGE_LINGUAS = ""
-
-# we dont need the kernel in the image
-ROOTFS_POSTPROCESS_COMMAND = "rm -f ${IMAGE_ROOTFS}/tmp/*Image*"
-# needed?? the above line is the same as in classes/nylon-image.bbclass
diff --git a/recipes/images/nylon-image-extended.bb b/recipes/images/nylon-image-extended.bb
deleted file mode 100644
index 4fb324d52f..0000000000
--- a/recipes/images/nylon-image-extended.bb
+++ /dev/null
@@ -1,84 +0,0 @@
-require nylon-image-base.bb
-require ../meta/nylon-feed.inc
-
-export IMAGE_BASENAME = "nylon-extended"
-
-NYLON_EXTENDED_DEPENDS = "${NYLON_FEED}"
-
-NYLON_EXTENDED_RDEPENDS = "\
- hostap-modules-cs \
- hostap-modules-pci \
- modutils-depmod \
- modutils-initscripts \
- modutils-modinfo \
- ntpdate \
- ntp-bin \
- ntp-tickadj \
- openssh-scp \
- openssh-ssh \
- openssh-sshd \
- perl-misc \
- perl-module-autoloader \
- perl-module-base \
- perl-module-bytes \
- perl-module-carp \
- perl-module-config \
- perl-module-constant \
- perl-module-data-dumper \
- perl-module-encode \
- perl-module-encode-alias \
- perl-module-encode-config \
- perl-module-encode-encoding \
- perl-module-encode-unicode \
- perl-module-errno \
- perl-module-exporter \
- perl-module-exporter-heavy \
- perl-module-fields \
- perl-module-getopt-long \
- perl-module-integer \
- perl-module-io \
- perl-module-io-handle \
- perl-module-io-socket \
- perl-module-io-socket-inet \
- perl-module-io-socket-unix \
- perl-module-locale \
- perl-module-overload \
- perl-module-posix \
- perl-module-selectsaver \
- perl-module-socket \
- perl-module-strict \
- perl-module-symbol \
- perl-module-sys-hostname \
- perl-module-vars \
- perl-module-warnings \
- perl-module-warnings-register \
- perl-module-xsloader \
-"
-
-KERNEL_MODULES = " \
- kernel-module-aes \
- kernel-module-bridge \
- kernel-module-ds \
- kernel-module-fat \
- kernel-module-mii \
- kernel-module-scsi-mod \
- kernel-module-sd-mod \
- kernel-module-usb-storage \
- kernel-module-usb-ohci \
- kernel-module-usbnet \
- kernel-module-usbserial \
- kernel-module-vfat \
- kernel-module-yenta-socket \
-"
-
-
-DEPENDS += "${NYLON_EXTENDED_DEPENDS}"
-
-IMAGE_INSTALL += "${NYLON_EXTENDED_DEPENDS} ${KERNEL_MODULES} \
- ${NYLON_EXTENDED_RDEPENDS} elvis-tools"
-
-IMAGE_INSTALL_append_mtx-1 = "\
- kernel-module-au1x00-bi \
- kernel-module-network-fd \
- kernel-module-usbdcore"
-# kernel-module-usbdprocfs \
diff --git a/recipes/images/nylon-image-extra.bb b/recipes/images/nylon-image-extra.bb
deleted file mode 100644
index e943a98fc0..0000000000
--- a/recipes/images/nylon-image-extra.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require nylon-image-standard.bb
-
-export IMAGE_BASENAME = "nylon-extra"
-
-IMAGE_INSTALL = "\
- kismet \
- netperf \
- nylon-statistics \
- openvpn"
diff --git a/recipes/images/nylon-image-mini.bb b/recipes/images/nylon-image-mini.bb
deleted file mode 100644
index f011cb171c..0000000000
--- a/recipes/images/nylon-image-mini.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-export IMAGE_BASENAME = "nylon-mini"
-
-inherit image
-
-NYLON_BASE = "base-files base-passwd busybox \
- dropbear \
- miniinit \
- modutils-collateral \
- modutils-initscripts \
- netbase \
- wireless-tools"
-
-IMAGE_INSTALL += "kernel ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
-IMAGE_LINGUAS = ""
diff --git a/recipes/images/nylon-image-standard.bb b/recipes/images/nylon-image-standard.bb
deleted file mode 100644
index 9238b0f8b2..0000000000
--- a/recipes/images/nylon-image-standard.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-require nylon-image-base.bb
-
-export IMAGE_BASENAME = "nylon-standard"
-
-NYLON_STANDARD = "\
- dash \
- dnsmasq \
- hostap-daemon hostap-utils \
- linux-hotplug \
- ifplugd \
- iproute2 \
- madwifi-modules \
- nylon-config \
- olsrd \
- ppp \
- rp-pppoe \
- simple-firewall \
- tcpdump \
- wpa-supplicant \
- yamonenv"
-
-DEPENDS += "hostap-modules ntp \
- ${NYLON_STANDARD}"
-
-IMAGE_INSTALL += "hostap-modules-pci ntpdate less nano elvis-tiny \
- ${NYLON_STANDARD}"
diff --git a/recipes/images/shr-image.inc b/recipes/images/shr-image.inc
index 81f5371a5a..674fea3363 100644
--- a/recipes/images/shr-image.inc
+++ b/recipes/images/shr-image.inc
@@ -3,12 +3,15 @@
#------------------------------------------------------
PV = "2.0"
-PR = "r17"
+PR = "r18"
DEPENDS += "task-shr-minimal"
IMAGE_LOGIN_MANAGER = "shadow"
IMAGE_DEV_MANAGER_om-gta01 = ""
IMAGE_DEV_MANAGER_om-gta02 = ""
+IMAGE_DEV_MANAGER_htcdream = ""
+IMAGE_DEV_MANAGER_nokia900 = ""
+IMAGE_DEV_MANAGER_nexusone = ""
RDEPENDS_${PN} += "\
task-shr-minimal-base \
@@ -48,6 +51,18 @@ shr_rootfs_gta01_postprocess() {
cd $curdir
}
+shr_rootfs_nokia900_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}/boot
+ echo "# Default kernel
+KERNEL=/boot/uImage
+LABEL=SHR kernel
+APPEND=root=/dev/mmcblk0p1 rootwait rw console=ttyO2,115200n8 console=tty0 omapfb.vram=0:2M,1:2M,2:2M mtdoops.mtddev=2 quiet
+ICON=/boot/default.xpm
+PRIORITY=100" > boot.cfg
+ cd $curdir
+}
+
# We don't want /boot directory in jffs2/ubi/ubifs images on gta01
IMAGE_CMD_jffs2_om-gta01 = "rm -rf ${IMAGE_ROOTFS}-boot; mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && mkfs.jffs2 -x lzo --root=${IMAGE_ROOTFS} --faketime --output=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 ${EXTRA_IMAGECMD}; mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
IMAGE_CMD_ubi_om-gta01 = "rm -rf ${IMAGE_ROOTFS}-boot; mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && echo \[ubifs\] > ubinize.cfg ; echo mode=ubi >> ubinize.cfg ; echo image=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubifs >> ubinize.cfg ; echo vol_id=0 >> ubinize.cfg ; echo vol_type=dynamic >> ubinize.cfg ; echo vol_name=${UBI_VOLNAME} >> ubinize.cfg ; echo vol_flags=autoresize >> ubinize.cfg;mkfs.ubifs -r ${IMAGE_ROOTFS} -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubifs ${MKUBIFS_ARGS} && ubinize -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubi ${UBINIZE_ARGS} ubinize.cfg; mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
@@ -58,3 +73,4 @@ ROOTFS_POSTPROCESS_COMMAND += " install_linguas;"
ROOTFS_POSTPROCESS_COMMAND_append_om-gta02 = " shr_rootfs_gta02_postprocess;"
ROOTFS_POSTPROCESS_COMMAND_append_om-gta01 = " shr_rootfs_gta01_postprocess;"
+ROOTFS_POSTPROCESS_COMMAND_append_nokia900 = " shr_rootfs_nokia900_postprocess;"
diff --git a/recipes/images/x11-at91sam9-image.bb b/recipes/images/x11-at91sam9-image.bb
index 39178731a3..d0ca0b64b6 100644
--- a/recipes/images/x11-at91sam9-image.bb
+++ b/recipes/images/x11-at91sam9-image.bb
@@ -1,13 +1,20 @@
# Angstrom x11-gpe-image with additional apps included
XSERVER = "xserver-xorg \
xf86-input-evdev \
- xf86-input-tslib \
- xf86-video-fbdev "
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard \
+ xinput-calibrator \
+ "
+# xf86-input-tslib \
+
require x11-gpe-image.bb
export IMAGE_BASENAME = "x11-at91sam9-image"
+# SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
+
DEPENDS = "task-base"
IMAGE_INSTALL += "\
@@ -39,17 +46,46 @@ IMAGE_INSTALL += "\
fbv \
dosfstools \
mtd-utils \
- gpe-mini-browser \
+# gpe-mini-browser2 \
tslib-conf \
tslib-calibrate \
tslib-tests \
libstdc++ \
- ${IMAGE_EXTRA_INSTALL} \
+ nano \
# nbench-byte \
-# pointercal \
+ pointercal \
+ gstreamer \
+ gst-plugins-base \
+ gst-plugins-good \
+ gst-plugins-bad \
+ gst-plugins-ugly \
+ gst-plugin-avi \
+ gst-plugin-mpegstream \
+ gst-plugin-qtdemux \
+ gst-plugin-mpegvideoparse \
+ gst-plugin-asf \
+ gst-plugin-alsa \
+ gst-plugin-ossaudio \
+ gst-plugin-audioresample \
+ gst-plugin-audioconvert \
+ gst-plugin-ximagesink \
+ gst-plugin-fbdevsink \
+ gst-plugin-faad \
+ gst-plugin-mad \
+ gst-plugin-playbin \
+ gst-plugin-decodebin \
+ gst-plugin-typefindfunctions \
+ gst-ffmpeg \
+# gst-plugin-on2-8170 \
+# on2-8170-libs \
+ owl-wifi \
"
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
# IMAGE_LINGUAS += " se no dk fi"
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
ROOTFS_POSTPROCESS_COMMAND += "set_image_autologin; "
ROOTFS_POSTPROCESS_COMMAND += "install_linguas; "
diff --git a/recipes/images/x11-at91sam9m10-image.bb b/recipes/images/x11-at91sam9m10-image.bb
new file mode 100644
index 0000000000..416ae636a3
--- /dev/null
+++ b/recipes/images/x11-at91sam9m10-image.bb
@@ -0,0 +1,102 @@
+#Angstrom X11 at91sam9 image
+
+XSERVER ?= ""
+
+ANGSTROM_EXTRA_INSTALL += " \
+ gpe-irc \
+ gpe-sketchbook \
+ gpe-filemanager \
+ gpe-tetris \
+ gpe-go \
+ gpe-calendar \
+ gpe-contacts \
+ gpe-edit \
+ gpe-gallery \
+ gpe-calculator \
+ gpe-clock \
+ gpe-terminal \
+ gpe-watch \
+ matchbox-panel-hacks \
+ gpe-scap \
+ gpe-windowlist \
+ gpe-mixer \
+ usbview \
+ mplayer \
+ thttpd \
+ madplay \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ iperf \
+ dosfstools \
+ mtd-utils \
+# nbench-byte \
+ gpe-mini-browser \
+ pointercal \
+ gstreamer \
+ gst-plugins-base \
+ gst-plugins-good \
+ gst-plugins-bad \
+ gst-plugins-ugly \
+ gst-plugin-avi \
+ gst-plugin-mpegstream \
+ gst-plugin-qtdemux \
+ gst-plugin-mpegvideoparse \
+ gst-plugin-asf \
+ gst-plugin-alsa \
+ gst-plugin-ossaudio \
+ gst-plugin-audioresample \
+ gst-plugin-audioconvert \
+ gst-plugin-ximagesink \
+ gst-plugin-fbdevsink \
+ gst-plugin-faad \
+ gst-plugin-mad \
+ gst-plugin-playbin \
+ gst-plugin-decodebin \
+ gst-plugin-typefindfunctions \
+ gst-ffmpeg \
+ gst-plugin-on2-8170 \
+ on2-8170-libs \
+ owl-wifi \
+ "
+
+export IMAGE_BASENAME = "x11-at91sam9m10-image"
+
+DEPENDS = "task-base"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ task-base-extended \
+ angstrom-x11-base-depends \
+ angstrom-gpe-task-base \
+ angstrom-gpe-task-settings \
+ ${ANGSTROM_EXTRA_INSTALL}"
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+at91sam9m10_rootfs_postprocess() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # add init script to cratee hantro modules /dev files
+ echo 'MAJOR=`cat /proc/devices |grep hx170|cut -f1 -d\ `' >> ${IMAGE_ROOTFS}//etc/init.d/hantro
+ echo 'mknod /dev/hx170 c $MAJOR 0' >> ${IMAGE_ROOTFS}/etc/init.d/hantro
+ echo 'MAJOR=`cat /proc/devices |grep memalloc|cut -f1 -d\ `' >> ${IMAGE_ROOTFS}//etc/init.d/hantro
+ echo 'mknod /dev/memalloc c $MAJOR 0' >> ${IMAGE_ROOTFS}/etc/init.d/hantro
+ chmod a+x ${IMAGE_ROOTFS}/etc/init.d/hantro
+ cd ${IMAGE_ROOTFS}/etc/rc5.d
+ ln -s ../init.d/hantro S51hantro
+
+ # back on track
+ cd $curdir
+}
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+ROOTFS_POSTPROCESS_COMMAND += "set_image_autologin; "
+
+#we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+
+#load sam9m10 vdec modules and create file descriptor at boot
+ROOTFS_POSTPROCESS_COMMAND += "at91sam9m10_rootfs_postprocess; "
+
+inherit image
diff --git a/recipes/images/x11-sato2-image.bb b/recipes/images/x11-sato2-image.bb
new file mode 100644
index 0000000000..e864782822
--- /dev/null
+++ b/recipes/images/x11-sato2-image.bb
@@ -0,0 +1,29 @@
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "opkg opkg-collateral"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+EVDEV_INSTALL = "\
+ xinput-calibrator \
+"
+
+IMAGE_INSTALL = "\
+ task-base-extended \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ pointercal \
+ ${XSERVER} \
+ xserver-common xserver-nodm-init \
+ ttf-liberation-sans ttf-liberation-serif ttf-liberation-mono \
+ xauth xhost xset xrandr \
+ xcursor-transparent-theme \
+ matchbox2 \
+ ${EVDEV_INSTALL} \
+"
+
+export IMAGE_BASENAME = "${PN}"
+IMAGE_LINGUAS = ""
+
+inherit image