aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb')
-rw-r--r--recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb b/recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
new file mode 100644
index 0000000000..8baffd24c7
--- /dev/null
+++ b/recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Itsy Package Manager utilities"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+CONFLICTS = "ipkg-link"
+RDEPENDS = "python"
+SRCDATE = "20050404"
+PR = "r23"
+
+SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \
+ file://ipkg-utils-fix.patch;patch=1 \
+ file://ipkg-py-sane-vercompare.patch;patch=1 \
+ file://ipkg-py-tarfile.patch;patch=1 \
+ file://arfile_even_alignment.patch;patch=1 \
+ file://ipkg-make-index-track-stamps.patch;patch=1 \
+ file://fields_tweaks.patch;patch=1 \
+ file://ipkg-env.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/ipkg-utils"
+
+INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py ipkg-list-fields"
+
+do_compile() {
+ oe_runmake ipkg-compare-versions
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ for i in ${INSTALL}
+ do
+ install -m 0755 $i ${D}${bindir}
+ done
+}
+