aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iqnotes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/iqnotes')
-rw-r--r--recipes/iqnotes/files/pro.patch10
-rw-r--r--recipes/iqnotes/iqnotes-2.0.2/md5.diff20
-rw-r--r--recipes/iqnotes/iqnotes-2.0.2/qt2310-fontbug.patch11
-rw-r--r--recipes/iqnotes/iqnotes.inc29
-rw-r--r--recipes/iqnotes/iqnotes_2.0.2.bb7
-rw-r--r--recipes/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb12
6 files changed, 89 insertions, 0 deletions
diff --git a/recipes/iqnotes/files/pro.patch b/recipes/iqnotes/files/pro.patch
new file mode 100644
index 0000000000..b2e5d881f9
--- /dev/null
+++ b/recipes/iqnotes/files/pro.patch
@@ -0,0 +1,10 @@
+--- iqnotes/iqnotes.pro.orig 2005-12-30 13:38:24.000000000 +0100
++++ iqnotes/iqnotes.pro 2005-12-30 13:39:01.000000000 +0100
+@@ -1,6 +1,5 @@
+ TEMPLATE = app
+-#CONFIG = qt warn_on pda
+-CONFIG = qt warn_on debug desktop
++CONFIG = qt warn_on pda
+ DEFINES = TOOLBAR_BIG_ICONS
+ pda:INCLUDEPATH += $(QPEDIR)/include
+ DESTDIR = ../bin
diff --git a/recipes/iqnotes/iqnotes-2.0.2/md5.diff b/recipes/iqnotes/iqnotes-2.0.2/md5.diff
new file mode 100644
index 0000000000..1cc7520d92
--- /dev/null
+++ b/recipes/iqnotes/iqnotes-2.0.2/md5.diff
@@ -0,0 +1,20 @@
+--- iqnotes/md5.cpp.orig 2004-02-08 19:34:32.000000000 +0000
++++ iqnotes/md5.cpp 2004-03-27 23:21:58.349894440 +0000
+@@ -151,7 +151,7 @@
+
+ while (stream.good())
+ {
+- stream.read(buffer, 1024); // note that return value of read is unusable.
++ stream.read((char *)buffer, 1024); // note that return value of read is unusable.
+ len=stream.gcount();
+ update(buffer, len);
+ }
+@@ -174,7 +174,7 @@
+
+ while (stream.good())
+ {
+- stream.read(buffer, 1024); // note that return value of read is unusable.
++ stream.read((char *)buffer, 1024); // note that return value of read is unusable.
+ len=stream.gcount();
+ update(buffer, len);
+ }
diff --git a/recipes/iqnotes/iqnotes-2.0.2/qt2310-fontbug.patch b/recipes/iqnotes/iqnotes-2.0.2/qt2310-fontbug.patch
new file mode 100644
index 0000000000..043b98d10b
--- /dev/null
+++ b/recipes/iqnotes/iqnotes-2.0.2/qt2310-fontbug.patch
@@ -0,0 +1,11 @@
+--- iqnotes/preferences.cpp.orig 2005-02-23 14:36:04 +0100
++++ iqnotes/preferences.cpp 2005-02-23 14:35:59 +0100
+@@ -106,7 +106,7 @@
+ {
+ QFontDatabase fontDB;
+ int currentSize = -1;
+-#ifdef DEBUG
++#if defined(DEBUG) || QT_VERSION >= 239
+ int f = 1;
+ #else
+ int f = 10;
diff --git a/recipes/iqnotes/iqnotes.inc b/recipes/iqnotes/iqnotes.inc
new file mode 100644
index 0000000000..f26e8cce9e
--- /dev/null
+++ b/recipes/iqnotes/iqnotes.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "IQNotes is notes kept in a hierarchical(tree like) manner. \
+It handles todo, events, sketching. It can acts as a contact, password, \
+credit card manager and even more, because is highly configurable. \
+Data can be crypted by strong AES algorithm."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://iqnotes.berlios.de"
+AUTHOR = "Peter Vrabel <kybu@kybu.org>"
+
+S = "${WORKDIR}/iqnotes/iqnotes"
+
+inherit palmtop
+
+QMAKE_PROFILES = "iqnotes.pro"
+export OE_QMAKE_LINK="${CXX}"
+
+do_install() {
+ install -d ${D}${palmtopdir}/help/html \
+ ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics/iqnotes/items \
+ ${D}${palmtopdir}/iqnotes/icons
+ install -m 0755 ${S}/../bin/iqnotes ${D}${palmtopdir}/bin/
+ install -m 0644 ${S}/../apps/Applications/*.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${S}/../pics/iqnotes/*.png ${D}${palmtopdir}/pics/iqnotes/
+ install -m 0644 ${S}/../help/html/iqnotes.html ${D}${palmtopdir}/help/html/
+ install -m 0644 ${S}/../pics/*.xpm ${D}${palmtopdir}/pics/
+}
diff --git a/recipes/iqnotes/iqnotes_2.0.2.bb b/recipes/iqnotes/iqnotes_2.0.2.bb
new file mode 100644
index 0000000000..7123f68bb2
--- /dev/null
+++ b/recipes/iqnotes/iqnotes_2.0.2.bb
@@ -0,0 +1,7 @@
+require iqnotes.inc
+
+PR = "r5"
+
+SRC_URI = "http://www.vanille.de/mirror/iqnotes-2.0.2-src.tar.bz2 \
+ file://md5.diff;patch=1 \
+ file://qt2310-fontbug.patch;patch=1"
diff --git a/recipes/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb b/recipes/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb
new file mode 100644
index 0000000000..e3288505eb
--- /dev/null
+++ b/recipes/iqnotes/iqnotes_2.0.99-2.1.0rc1.bb
@@ -0,0 +1,12 @@
+require iqnotes.inc
+
+#upstream version
+UPV = "2.1.0rc1"
+PR = "r2"
+
+SRC_URI = "http://download.berlios.de/iqnotes/iqnotes-${UPV}.tar.bz2 \
+ file://pro.patch;patch=1"
+
+S = "${WORKDIR}/iqnotes-${UPV}/iqnotes/"
+
+EXTRA_QMAKEVARS_POST += "CONFIG-=desktop CONFIG-=debug CONFIG+=pda LIBS-=-lqtopia"