aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ivman/ivman_0.6.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ivman/ivman_0.6.14.bb')
-rw-r--r--recipes/ivman/ivman_0.6.14.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/ivman/ivman_0.6.14.bb b/recipes/ivman/ivman_0.6.14.bb
new file mode 100644
index 0000000000..ecc4665b9b
--- /dev/null
+++ b/recipes/ivman/ivman_0.6.14.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Daemon to mount/unmount devices, based on info from HAL"
+HOMEPAGE = "http://ivman.sf.net"
+LICENSE = "GPLv2"
+PR = "r1"
+
+DEPENDS = "hal libxml2"
+RDEPENDS = "hal pmount-hal"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ivman/${P}.tar.bz2 \
+ file://ivman-0.6-hotpluggable.patch;patch=1 \
+ file://ivman-launch.patch;patch=1 "
+
+inherit autotools
+
+# Add user ivman into group plugdev
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ grep "^ivman:" /etc/passwd > /dev/null || \
+ adduser --disabled-password --system --home /dev/null \
+ --no-create-home --ingroup plugdev -s /bin/false \
+ -g "IVMAN" ivman
+ /etc/init.d/populate-volatile.sh update
+}
+
+pkg_postrm_${PN} () {
+ deluser ivman || true
+}