aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iw/iw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/iw/iw_git.bb')
-rw-r--r--recipes/iw/iw_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/iw/iw_git.bb b/recipes/iw/iw_git.bb
new file mode 100644
index 0000000000..c98e1bc5f7
--- /dev/null
+++ b/recipes/iw/iw_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "nl80211 based CLI configuration utility for wireless devices"
+HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/iw"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRCREV = "0a236ef5f8e4ba7218aac7d0cdacf45673d5b35c"
+PR = "r0"
+PV = "0.9.22"
+PR_append = "+gitr${SRCPV}"
+
+DEPENDS = "libnl pkgconfig"
+
+SRC_URI = " \
+ git://git.sipsolutions.net/iw.git;protocol=git \
+ "
+CFLAGS += "-DCONFIG_LIBNL20"
+
+S = "${WORKDIR}/git/"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}