aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jamvm/jamvm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jamvm/jamvm')
-rw-r--r--recipes/jamvm/jamvm/debian-jni.patch19
-rw-r--r--recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch12
-rw-r--r--recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch13
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/jamvm/jamvm/debian-jni.patch b/recipes/jamvm/jamvm/debian-jni.patch
new file mode 100644
index 0000000000..040163da69
--- /dev/null
+++ b/recipes/jamvm/jamvm/debian-jni.patch
@@ -0,0 +1,19 @@
+--- src/dll.c.orig 2004-09-09 15:48:45.000000000 +0000
++++ src/dll.c 2004-09-09 15:50:32.000000000 +0000
+@@ -189,6 +189,16 @@
+ #ifndef NO_JNI
+ /* Init hash table, and create lock */
+ initHashTable(hash_table, HASHTABSZE, TRUE);
++
++ /* XXX: Add Debian JNI directory. */
++ char* path = getenv("LD_LIBRARY_PATH");
++
++ if (path != NULL)
++ path = strcat(path, ":OE_LIBDIR_JNI");
++ else
++ path = "OE_LIBDIR_JNI";
++
++ setenv("LD_LIBRARY_PATH", path, 1);
+ #endif
+ }
+
diff --git a/recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch b/recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch
new file mode 100644
index 0000000000..a41beee982
--- /dev/null
+++ b/recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch
@@ -0,0 +1,12 @@
+--- jamvm-1.3.1.orig/src/jam.h 2005-07-17 23:53:34.000000000 +0200
++++ jamvm-1.3.1/src/jam.h 2005-07-17 23:54:17.000000000 +0200
+@@ -548,7 +548,9 @@
+ #endif
+
+ /* default size of the Java stack */
++#ifndef DEFAULT_STACK
+ #define DEFAULT_STACK 64*KB
++#endif
+
+ /* size of emergency area - big enough to create
+ a StackOverflow exception */
diff --git a/recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch b/recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch
new file mode 100644
index 0000000000..f0884fd838
--- /dev/null
+++ b/recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch
@@ -0,0 +1,13 @@
+Index: jamvm-1.5.3/src/Makefile.am
+===================================================================
+--- jamvm-1.5.3.orig/src/Makefile.am 2009-09-29 09:29:13.386565473 +0200
++++ jamvm-1.5.3/src/Makefile.am 2009-09-29 09:33:47.702565852 +0200
+@@ -23,7 +23,7 @@
+ DIST_SUBDIRS = os arch interp
+
+ bin_PROGRAMS = jamvm
+-include_HEADERS = jni.h
++noinst_HEADERS = jni.h
+
+ lib_LTLIBRARIES = libjvm.la
+ noinst_LTLIBRARIES = libcore.la