aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jamvm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jamvm')
-rw-r--r--recipes/jamvm/jamvm-initial_1.4.5.bb2
-rw-r--r--recipes/jamvm/jamvm-initial_1.5.0.bb7
-rw-r--r--recipes/jamvm/jamvm-native_1.5.3.bb2
-rw-r--r--recipes/jamvm/jamvm_1.4.5.bb2
-rw-r--r--recipes/jamvm/jamvm_1.5.0.bb2
-rw-r--r--recipes/jamvm/jamvm_1.5.2.bb2
-rw-r--r--recipes/jamvm/jamvm_1.5.3.bb15
7 files changed, 23 insertions, 9 deletions
diff --git a/recipes/jamvm/jamvm-initial_1.4.5.bb b/recipes/jamvm/jamvm-initial_1.4.5.bb
index 200c0168c1..fb2f4bf330 100644
--- a/recipes/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes/jamvm/jamvm-initial_1.4.5.bb
@@ -11,7 +11,7 @@ PROVIDES = "virtual/java-initial"
S = "${WORKDIR}/jamvm-${PV}"
SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
- file://jamvm_${PV}-initial.patch;patch=1;pnum=1 \
+ file://jamvm_${PV}-initial.patch \
"
# This uses 32 bit arm, so force the instruction set to arm, not thumb
diff --git a/recipes/jamvm/jamvm-initial_1.5.0.bb b/recipes/jamvm/jamvm-initial_1.5.0.bb
index c56dc754a4..3986861a1a 100644
--- a/recipes/jamvm/jamvm-initial_1.5.0.bb
+++ b/recipes/jamvm/jamvm-initial_1.5.0.bb
@@ -11,7 +11,7 @@ PROVIDES = "virtual/java-initial"
S = "${WORKDIR}/jamvm-${PV}"
SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
- file://jamvm_${PV}-initial.patch;patch=1;pnum=1 \
+ file://jamvm_${PV}-initial.patch \
"
# This uses 32 bit arm, so force the instruction set to arm, not thumb
@@ -36,9 +36,8 @@ do_compile() {
GLIBJ_ZIP=${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip
}
-do_stage_append() {
- install -d ${STAGING_BINDIR}
- install -m 0755 java-initial ${STAGING_BINDIR}
+do_install_append() {
+ install -m 0755 java-initial ${D}${bindir}
}
SRC_URI[md5sum] = "a965452442cdbfc94caba57d0dd25a8f"
diff --git a/recipes/jamvm/jamvm-native_1.5.3.bb b/recipes/jamvm/jamvm-native_1.5.3.bb
index 73b43fb064..10036efd1f 100644
--- a/recipes/jamvm/jamvm-native_1.5.3.bb
+++ b/recipes/jamvm/jamvm-native_1.5.3.bb
@@ -4,7 +4,7 @@ require jamvm-native.inc
PR = "r1"
-SRC_URI += "file://jamvm-1.5.3-jni_h-noinst.patch;patch=1"
+SRC_URI += "file://jamvm-1.5.3-jni_h-noinst.patch"
SRC_URI[md5sum] = "ce886163658d748113b0570dfae12aea"
diff --git a/recipes/jamvm/jamvm_1.4.5.bb b/recipes/jamvm/jamvm_1.4.5.bb
index 0d353a7fd0..0e9636622b 100644
--- a/recipes/jamvm/jamvm_1.4.5.bb
+++ b/recipes/jamvm/jamvm_1.4.5.bb
@@ -2,7 +2,7 @@ require jamvm.inc
PR = "r3"
-SRC_URI += "file://jamvm-1.3.1-size-defaults.patch;patch=1"
+SRC_URI += "file://jamvm-1.3.1-size-defaults.patch"
SRC_URI[md5sum] = "3f538bab6e1c77aed331e5e71f754f5b"
diff --git a/recipes/jamvm/jamvm_1.5.0.bb b/recipes/jamvm/jamvm_1.5.0.bb
index be8cb4cc8b..2231566bb0 100644
--- a/recipes/jamvm/jamvm_1.5.0.bb
+++ b/recipes/jamvm/jamvm_1.5.0.bb
@@ -1,6 +1,6 @@
require jamvm.inc
-SRC_URI += "file://debian-jni.patch;patch=1;pnum=0"
+SRC_URI += "file://debian-jni.patch;striplevel=0"
PR = "r4"
diff --git a/recipes/jamvm/jamvm_1.5.2.bb b/recipes/jamvm/jamvm_1.5.2.bb
index 258629684c..68949ab44d 100644
--- a/recipes/jamvm/jamvm_1.5.2.bb
+++ b/recipes/jamvm/jamvm_1.5.2.bb
@@ -1,6 +1,6 @@
require jamvm.inc
-SRC_URI += "file://debian-jni.patch;patch=1;pnum=0"
+SRC_URI += "file://debian-jni.patch;striplevel=0"
PR = "r0"
diff --git a/recipes/jamvm/jamvm_1.5.3.bb b/recipes/jamvm/jamvm_1.5.3.bb
new file mode 100644
index 0000000000..19eabfd669
--- /dev/null
+++ b/recipes/jamvm/jamvm_1.5.3.bb
@@ -0,0 +1,15 @@
+require jamvm.inc
+
+SRC_URI += "file://debian-jni.patch;striplevel=0"
+
+PR = "r0"
+
+do_configure_prepend() {
+ # Replaces the placeholder OE_LIBDIR_JNI with the JNI library directory
+ # configured in OE.
+ sed -i -e "s|OE_LIBDIR_JNI|${libdir_jni}|" src/dll.c
+}
+
+SRC_URI[md5sum] = "ce886163658d748113b0570dfae12aea"
+SRC_URI[sha256sum] = "f2795ab62635df1c9bc6c4a7b90f53d0d846c0c26f5ec7b352f687506407ebd8"
+