aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jikes/jikes-initial.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jikes/jikes-initial.bb')
-rw-r--r--recipes/jikes/jikes-initial.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/jikes/jikes-initial.bb b/recipes/jikes/jikes-initial.bb
new file mode 100644
index 0000000000..0e2f4d0748
--- /dev/null
+++ b/recipes/jikes/jikes-initial.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
+
+DEPENDS = "jikes-native classpath-initial"
+
+SRC_URI = ""
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ echo "#!/bin/sh" > jikes-initial
+ echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 jikes-initial ${STAGING_BINDIR}
+}