aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/junit/junit4_4.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/junit/junit4_4.3.1.bb')
-rw-r--r--recipes/junit/junit4_4.3.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/junit/junit4_4.3.1.bb b/recipes/junit/junit4_4.3.1.bb
new file mode 100644
index 0000000000..2733aff2e1
--- /dev/null
+++ b/recipes/junit/junit4_4.3.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSES = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
+
+S = "${WORKDIR}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -source 5.0 -bootclasspath $bcp -sourcepath . -d build `find . -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}