aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch')
-rw-r--r--recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch b/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch
new file mode 100644
index 0000000000..cd2fa6ca2d
--- /dev/null
+++ b/recipes/kexecboot/linux-kexecboot/fix.module.loading.16310.patch
@@ -0,0 +1,28 @@
+From 1cb348e903f81bb34abe00c9a06b42009ddca819 Mon Sep 17 00:00:00 2001
+From: Michal Marek <mmarek@suse.cz>
+Date: Fri, 2 Jul 2010 13:17:37 +0200
+Subject: [PATCH] arm: Build with -fno-dwarf2-cfi-asm
+
+Commit d0679c7 restricted this workaround to powerpc only, but it turns
+out that ARM needs it as well. Fixes
+https://bugzilla.kernel.org/show_bug.cgi?id=16310 .
+
+Reported-by: Robert Nelson <robertcnelson@gmail.com>
+Signed-off-by: Michal Marek <mmarek@suse.cz>
+
+diff --git a/arch/arm/Makefile b/arch/arm/Makefile
+index 64ba313..862d4ba 100644
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -21,6 +21,11 @@ GZFLAGS :=-9
+ # Explicitly specifiy 32-bit ARM ISA since toolchain default can be -mthumb:
+ KBUILD_CFLAGS +=$(call cc-option,-marm,)
+
++# FIXME: the module load should be taught about the additional relocs
++# generated by this.
++# revert to pre-gcc-4.4 behaviour of .eh_frame
++KBUILD_CFLAGS += $(call cc-option,-fno-dwarf2-cfi-asm)
++
+ # Do not use arch/arm/defconfig - it's always outdated.
+ # Select a platform tht is kept up-to-date
+ KBUILD_DEFCONFIG := versatile_defconfig