aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexecboot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/kexecboot')
-rw-r--r--recipes/kexecboot/linux-kexecboot-2.6.32+2.6.33-rc5/ARM-Add-support-for-LZMA-compressed-kernel-images.patch51
-rw-r--r--recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc5.bb3
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes/kexecboot/linux-kexecboot-2.6.32+2.6.33-rc5/ARM-Add-support-for-LZMA-compressed-kernel-images.patch b/recipes/kexecboot/linux-kexecboot-2.6.32+2.6.33-rc5/ARM-Add-support-for-LZMA-compressed-kernel-images.patch
new file mode 100644
index 0000000000..42905c552e
--- /dev/null
+++ b/recipes/kexecboot/linux-kexecboot-2.6.32+2.6.33-rc5/ARM-Add-support-for-LZMA-compressed-kernel-images.patch
@@ -0,0 +1,51 @@
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 350921d..34163da 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -20,6 +20,7 @@ config ARM
+ select HAVE_GENERIC_DMA_COHERENT
+ select HAVE_KERNEL_GZIP
+ select HAVE_KERNEL_LZO
++ select HAVE_KERNEL_LZMA
+ help
+ The ARM series is a line of low-power-consumption RISC chip designs
+ licensed by ARM Ltd and targeted at embedded applications and
+diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
+index 2d4d88b..3906432 100644
+--- a/arch/arm/boot/compressed/Makefile
++++ b/arch/arm/boot/compressed/Makefile
+@@ -65,6 +65,7 @@ SEDFLAGS = s/TEXT_START/$(ZTEXTADDR)/;s/BSS_START/$(ZBSSADDR)/
+
+ suffix_$(CONFIG_KERNEL_GZIP) = gzip
+ suffix_$(CONFIG_KERNEL_LZO) = lzo
++suffix_$(CONFIG_KERNEL_LZMA) = lzma
+
+ targets := vmlinux vmlinux.lds \
+ piggy.$(suffix_y) piggy.$(suffix_y).o \
+diff --git a/arch/arm/boot/compressed/misc.c b/arch/arm/boot/compressed/misc.c
+index 7e0fe4d..4e35a10 100644
+--- a/arch/arm/boot/compressed/misc.c
++++ b/arch/arm/boot/compressed/misc.c
+@@ -252,6 +252,10 @@
+ #include "../../../../lib/decompress_unlzo.c"
+ #endif
+
++#ifdef CONFIG_KERNEL_LZMA
++#include "../../../../lib/decompress_unlzma.c"
++#endif
++
+ #ifndef arch_error
+ #define arch_error(x)
+ #endif
+diff --git a/arch/arm/boot/compressed/piggy.lzma.S b/arch/arm/boot/compressed/piggy.lzma.S
+new file mode 100644
+index 0000000..d7e69cf
+--- /dev/null
++++ b/arch/arm/boot/compressed/piggy.lzma.S
+@@ -0,0 +1,6 @@
++ .section .piggydata,#alloc
++ .globl input_data
++input_data:
++ .incbin "arch/arm/boot/compressed/piggy.lzma"
++ .globl input_data_end
++input_data_end:
diff --git a/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc5.bb b/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc5.bb
index c2afd11d99..9edf26d4ed 100644
--- a/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc5.bb
+++ b/recipes/kexecboot/linux-kexecboot_2.6.32+2.6.33-rc5.bb
@@ -3,7 +3,7 @@ require linux-kexecboot.inc
KERNEL_RELEASE = "2.6.33-rc5"
OLD_KERNEL_RELEASE = "2.6.32"
PV = "${OLD_KERNEL_RELEASE}+${KERNEL_RELEASE}"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/linux-${OLD_KERNEL_RELEASE}"
@@ -18,6 +18,7 @@ DEFAULT_PREFERENCE_tosa = "-1"
SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${OLD_KERNEL_RELEASE}.tar.bz2;name=kernel \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-${KERNEL_RELEASE}.bz2;name=rc5;patch=1 \
+ file://ARM-Add-support-for-LZMA-compressed-kernel-images.patch;patch=1;status=pending \
file://defconfig"
SRC_URI[rc5.md5sum] = "3185d51085c89139cca7ce78a8e8a7f8"