summaryrefslogtreecommitdiffstats
path: root/recipes/keylaunch/files/makefile-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/keylaunch/files/makefile-fix.patch')
-rw-r--r--recipes/keylaunch/files/makefile-fix.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/keylaunch/files/makefile-fix.patch b/recipes/keylaunch/files/makefile-fix.patch
new file mode 100644
index 0000000000..d9c57e05ac
--- /dev/null
+++ b/recipes/keylaunch/files/makefile-fix.patch
@@ -0,0 +1,15 @@
+--- keylaunch-2.0.10/Makefile.orig 2007-05-25 18:13:39.000000000 +0200
++++ keylaunch-2.0.10/Makefile 2007-05-25 18:15:47.000000000 +0200
+@@ -31,8 +31,10 @@
+ $(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
+
+ install-program: all
+- install -sD $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
+- install -D -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -s $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG)
++ install -d $(DESTDIR)/etc
++ install -m 644 $(PROG)rc $(DESTDIR)/etc/$(PROG)rc
+ install -d $(DESTDIR)/etc/X11/Xsession.d
+ install 90$(PROG) $(DESTDIR)/etc/X11/Xsession.d/90$(PROG)
+ install -d $(DESTDIR)/etc/X11/Xinit.d