aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lame/lame
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lame/lame')
-rw-r--r--recipes/lame/lame/Makefile-lm.patch22
-rw-r--r--recipes/lame/lame/no-gtk1.patch16
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/lame/lame/Makefile-lm.patch b/recipes/lame/lame/Makefile-lm.patch
new file mode 100644
index 0000000000..cbbb1706ce
--- /dev/null
+++ b/recipes/lame/lame/Makefile-lm.patch
@@ -0,0 +1,22 @@
+--- lame-3.96.1/libmp3lame/Makefile.am.old 2007-01-16 13:41:48.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.am 2007-01-16 13:41:53.000000000 +0000
+@@ -18,7 +18,7 @@
+ decoder_ldadd =
+ endif
+
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+ -no-undefined
+
+--- lame-3.96.1/libmp3lame/Makefile.in.old 2007-01-16 13:47:17.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.in 2007-01-16 13:47:29.000000000 +0000
+@@ -177,7 +177,7 @@
+ @LIB_WITH_DECODER_TRUE@decoder_ldadd = $(top_builddir)/mpglib/libmpgdecoder.la
+ @LIB_WITH_DECODER_FALSE@decoder_ldadd =
+
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+ -no-undefined
+
diff --git a/recipes/lame/lame/no-gtk1.patch b/recipes/lame/lame/no-gtk1.patch
new file mode 100644
index 0000000000..4f1a522186
--- /dev/null
+++ b/recipes/lame/lame/no-gtk1.patch
@@ -0,0 +1,16 @@
+--- lame-3.96.1/configure.in~no-gtk1.patch 2004-07-25 15:52:12.000000000 +0100
++++ lame-3.96.1/configure.in 2004-09-10 15:54:39.000000000 +0100
+@@ -363,7 +363,12 @@
+
+ dnl configure use of features
+
+-AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
++#AM_PATH_GTK(1.2.0, HAVE_GTK="yes", HAVE_GTK="no")
++HAVE_GTK="no"
++GTK_CFLAGS=""
++GTK_LIBS=""
++AC_SUBST(GTK_CFLAGS)
++AC_SUBST(GTK_LIBS)
+ if test "${HAVE_GTK}" = "yes"; then
+ AC_DEFINE(HAVE_GTK, 1, have working GTK)
+ fi