aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lcdproc/lcdproc_0.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lcdproc/lcdproc_0.5.1.bb')
-rw-r--r--recipes/lcdproc/lcdproc_0.5.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/lcdproc/lcdproc_0.5.1.bb b/recipes/lcdproc/lcdproc_0.5.1.bb
new file mode 100644
index 0000000000..dafcbba170
--- /dev/null
+++ b/recipes/lcdproc/lcdproc_0.5.1.bb
@@ -0,0 +1,19 @@
+require lcdproc5.inc
+
+DEPENDS += "libg15 g15daemon libg15render"
+DEPENDS_lcdd-driver-all += "lcdd-driver-g15"
+
+PR = "r3"
+
+do_install_append () {
+ # binaries
+ install -D -m 0755 clients/lcdvc/lcdvc ${D}${sbindir}/lcdvc
+
+ # configuration files
+ install -D -m 0644 clients/lcdvc/lcdvc.conf ${D}${sysconfdir}/lcdvc.conf
+}
+
+PACKAGES =+ "lcdvc lcdd-driver-g15"
+CONFFILES_lcdvc = "${sysconfdir}/lcdvc.conf"
+FILES_lcdvc = "${CONFFILES_lcdvc} ${sbindir}/lcdvc"
+FILES_lcdd-driver-g15 = "${libdir}/lcdproc/g15.so"