summaryrefslogtreecommitdiffstats
path: root/recipes/lcms
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lcms')
-rw-r--r--recipes/lcms/lcms-native_1.17.bb5
-rw-r--r--recipes/lcms/lcms_1.13.bb10
-rw-r--r--recipes/lcms/lcms_1.17.bb14
3 files changed, 29 insertions, 0 deletions
diff --git a/recipes/lcms/lcms-native_1.17.bb b/recipes/lcms/lcms-native_1.17.bb
new file mode 100644
index 0000000000..e5771ca26a
--- /dev/null
+++ b/recipes/lcms/lcms-native_1.17.bb
@@ -0,0 +1,5 @@
+require lcms_${PV}.bb
+
+PR = "r0"
+
+inherit native
diff --git a/recipes/lcms/lcms_1.13.bb b/recipes/lcms/lcms_1.13.bb
new file mode 100644
index 0000000000..af1869e75d
--- /dev/null
+++ b/recipes/lcms/lcms_1.13.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Little cms is a small-footprint, speed optimized color management engine."
+SECTION = "libs"
+LICENSE = "LGPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lcms/lcms-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C src/.libs/ liblcms ${STAGING_LIBDIR}
+}
diff --git a/recipes/lcms/lcms_1.17.bb b/recipes/lcms/lcms_1.17.bb
new file mode 100644
index 0000000000..2336142a23
--- /dev/null
+++ b/recipes/lcms/lcms_1.17.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Little cms is a small-footprint, speed optimized color management engine."
+SECTION = "libs"
+LICENSE = "LGPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lcms/lcms-${PV}.tar.gz"
+
+PR = "r2"
+
+inherit autotools
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}